Brave sync on iOS is completely broken and has been for many months! - plus other bugs with sync on iOS too. (iOS) If you have iOS please read!

Firstly to say if you have iOS, you will have this bug so please check and reply!
More replies with people having the same issue, the better.

2 major bugs I found that I can reproduce every time without fail that leave iOS sync completely unusable! Also 1 other issue totalling 3 issues. All about sync on iOS.

Sync is broken on iOS and unusable.

I have been using Brave on PC and iPhone and iPad with no issues for about 8 months or so until just over a month ago when these 2 bugs were found.

This is something that started around September/October 2021. Hard to say exactly when as I only noticed when the bookmarks hadn’t synced at all.

First issue

Description of the issue:
iOS sync is broken and I can reproduce it to show you.
I have the latest Brave and my iPad and iPhone and they stop syncing the day you connect them!

I only found as the bookmarks weren’t syncing and I had added some bookmarks so I went into sync and saw the last sync date as being ages ago!
You are on the sync chain, but the iOS devices just don’t sync after the initial sync so you don’t have any newly added bookmarks and a last sync date of the date you did the initial sync chain. It doesn’t sync after that.

They are still in the sync chain but show as last connected as the day you connected them to sync.
They only sync initially when you add them to the chain and they it stops syncing again.

This happens on both my iOS devices.
My iPad and iPhone who are connected to my windows laptop.
The windows laptop is used every day and has no issues but the iOS devices stop syncing after connecting them to the chain. The PC carries on syncing no issues.
Both iOS devices stop syncing after you initially connect them and never sync again until you add them to the chain again manually.

Steps to Reproduce

  1. Go to sync
  2. connect your devices up
  3. It won’t sync anything after this point. It will show as connected via sync but it doesn’t sync on iPhone or iPad. It will have a sync day of the last time you made the sync chain but after you connect sync it dies and will NEVER sync again!

I have reinstalled all apps and created new chains to see if it was a chain issue but it always does the same thing and they stop syncing.

The moment you have synced it is the last time the iOS devices will sync. They won’t ever sync again until I manually add them again.

Reproduces how often:
Every time!

This has happened every day over the last month or so, and I have to keep re-adding items to sync over and over as they only sync once on iOS now!
I have to make a new sync every single time I want to send a bookmark to iOS or vice versa as it just won’t sync on iOS anymore.


Second issue

Description of the issue:

I also found out another issue with sync on iPhone where the sync page will usually close down and remove the device from the sync chain, even though it actually leaves it on the sync chain as you can see it still connected if you check another device.
It removes the device from the chain but actually leaves it there so you have to manually remove it and add it back again.

I open settings on the iPhone, navigate to sync, open sync under settings and it often quickly closes the page down and leaves any chain it was connected to.
Like the sync settings page just crashes.
Sometimes it will be fine the first time but if you go in another once or twice it will close the page down and remove the device from the sync chain.

It happens on iPhone and iPad, although more often on iPhone than iPad which is odd, but if you keep opening the sync settings page over and over, after the second or third time it will still close the tab down and remove the device from the sync yet leave it on the sync chain.

Steps to Reproduce

  1. On iPhone, go into settings - sync
  2. if it is ok, go back out and in again, but it will most likely crash the sync settings screen right here!
  3. Repeat if nothing happens one or two times as it always happens.
  4. It will remove that device out of the sync chain, yet leave it actually connected if you check on another device such as PC.
  5. You now have to remove the device from another device and re-add it other wise if you just re-add it here, you will have 2 instances of the same device as when the page crashes it removes the device BUT leaves it on the sync chain in reality which you can see from another device on the same chain.

Reproduces how often:
I can do it every time. Sometimes takes just one attempt, sometimes it is the second or third time you go in but I can always reproduce it.

I have make both iOS devices actually leave the chain via my laptop where it shows there are still connected even though they are not, and join the sync again.

Also it takes multiple attempts to even connect iOS devices now (since last few weeks) as it shows connected but on other devices it shows not connected so I have to keep leaving and connecting over and over and over again all for 1 day of sync as the iOS devices both stop syncing instantly!


Third issue

Description of the issue:
On iOS if you try to add a device using QR code it often freezes totally and you can’t do a thing. I have to use the words instead.
Sometimes it works but it usually doesn’t. The words always work.

Brave Version
Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (64-bit)
On iOS and iPados they are both on the latest version of iOS 15 and iPados 15

Type of devices currently running on the Sync chain in question:
Windows 10 PC (has no issues with sync)
iPad Air 2
iPhone XS Max

I spent a lot of time writing this out after finding these bugs
I hope it can be fixed soon as all the info here is all you need to reproduce both of them!

UPDATE 11th March 2022
This is still happening. Been happening for around 5 or 6 months.
The devs are trying to figure out what the cause is still.
They are adding/added debugging so they can see more details, in a hope of figuring out the cause so they can fix it.
I still have contact with 2 of the devs and will update if I hear back from them.

You can check the releases on desktop and mobile here, just in case they post when they fix it, although I will post once I hear it is fixed.
Until then, it is not fixed as they haven’t figured out the cause yet.

It is pointless trying every day to see if it is working yet as I know some are doing and I used to do the same, but they haven’t found the cause yet and are still working on fixing it.

I will post if I hear when it is fixed which they said they would let me know, or a dev may come and let you know when it is fixed as they do look at this thread now and again.

UPDATE APRIL 2022
The last update that added debugging seemed to fix the issue #1 of the sync dropping, for me and many others, and I haven’t had it since.
I spoke to the devs again and they said if people can comment here if you are still having the issue and upload photos.
The update was adding debugging and wasn’t meant to fix it, but something did fix it for most of us. If you are still having issues, please post here.

42 Likes

And again the devices haven’t synced since the day I had to re-add them to the sync chain.
This happens constantly!!

Losing favourites as they aren’t syncing across all devices…

9 Likes

i’m also getting this.

6 Likes

It is every day now!
I have connected my devices 10 times now and they stop syncing the day I connect them!
Every single time!

PC still syncs but my iOS devices don’t

I have been using it fine for about 8 months until just a few weeks ago!

I reconnected my iPhone AGAIN as I have to do every time and again when I went into settings - sync for the second time, it disconnected the sync AGAIN.

7 Likes

Thank you for reporting this issue, @ukheather. When you say the iPad and iPhone stop syncing, do you mean they no longer send their data to the desktop device, or the desktop no longer sends its data to the iOS devices?

When the iOS sync page crashes, and it appears as though the devices have been removed from the sync chain, do you eventually see these devices removed from the brave://sync/ page on the desktop device too?

When these devices (iPad and iPhone) are re-added to a sync chain, are they being added to the existing sync chain upon which the desktop currently resides, or are you creating a new sync chain each time (and adding all devices to that)?

Thank you again for your patience, and helping us to gain a better understanding of this issue. I look forward to doing whatever I can to improve your experience with Brave as promptly as possible.

6 Likes

Yes they no longer send any data.
They show as connected but don’t sync on iPad or iPhone after the initial sync.
PC remains fine.

On iPhone if I open sync settings multiple times it loads back to the previous page and that will remove me from any sync chain ALTHOUGH on PC I can still see that it shows as still on the sync chain.

When I add them I have tried adding to same chain many times and also starting a new chain many times. Nothing works. It fails to sync after the initial sync for both iOS devices no matter what.

And as for the iOS issue where if you open settings - sync once or twice and it removes me from the sync, it still shows as on the sync chain on PC but it gets removed.

So 2 different issues, 1. the sync being broken on iOS and then 2. the issue with the sync on iOS where it returns you to the settings page and removes you from sync.

Been fine for 8 months so something has changed.
There are other posts on this forum with similar issues unresolved.

Another thread saying iOS sync is broken

3 Likes

Hi, I’m getting exactly the same issue, on iOS 15.1.1.

  • Desktop Brave Version 1.32.113 Chromium: 96.0.4664.45
  • iOS App Version 1.32.3 (21.11.17.19)

When I say exactly the same, I mean word for word, including the crashing of the Sync page and the iPhone appearing to remove itself from the Sync Chain on the iOS app, while remaining in the desktop’s Settings.

4 Likes

Thanks for sharing you have it too.

I bet most people are but they don’t know until they go into sync or to find a bookmark.

I hope this can be fixed as it isn’t just me and it makes sync unusable on iOS.

4 Likes

Every day I edit my bookmarks I have to add my iOS devices back to the chain so I can sync my bookmarks now…

Sync is totally unusable on iOS with this bug.

I can replicate it 100% of the time.

  1. create a sync chain
  2. have at least 2 devices on the sync chain. At least 1 iOS device and also a pc or non-iOS device
  3. add a bookmark to one device
  4. check the other device to see if it synced & it won’t have & never will. (PC syncs fine but iOS only syncs the initial time when you add it to the sync chain)

If you have PC, check the sync date under settings and you will see the last time your iOS device synced.

I have to redo the sync chain every single time I add a bookmark…

This is easy to replicate and I personally think everyone with iOS will have this issue but they won’t know until they try to sync a new bookmark or check the last sync dates.

Has been broken a while now.

I have tried new chains to see if that helped but it doesn’t.

It is like something happened the other month that broke iOS sync as it was fine for so many months.

4 Likes

If you have it too, please reply and let us know.

If you don’t think you have it, please follow the step as I personally think it will be on all iOS devices but most won’t know unless they try to sync a bookmark or go into sync settings.

If you sync PC to iOS, you can check the browser on PC and see the last sync date so you can see if you iOS device is still syncing or not.

2 Likes

I have the same problem. Hope this gets resolved soon. Will probably use a different browser until this gets resolved. I cannot stand having to manually update things when sync should work.

5 Likes

Same problem.
reproduction steps already stated above.
I thought sync was finally fixed this year ): This is a key feature!
Could be connected to iOS15 update, but can’t confirm

4 Likes

Still happening.
Been a LONG time now and lots if not all are affected.

I am pretty sure everyone with an iOS device is affected but as I said you don’t know until you check.
So if you are reading this and are not affected, please check as I am sure you are.

4 Likes

I just switched to Brave and cant even get through the sync setup on iOS. The process freezes as soon as you scan a QR code or select a device type.

3 Likes

yep I have that too with QR code so have to use the words

2 Likes

Same problems here, absolutely exact same steps and bugs with Sync. I have iPhone 11 with iOS 15.2 and Brave iOS: 1.32.3 (21.11.17.19). Sync Chain is working nice between 3 my PCs and iOS is having problems

1 Like

Been having the same problem as well MacOS Monterey (Brave v 1.33.106) /iPad Pro (Brave v 1.32.3)/iPhone (Brave v 1.32.3) for quite a while now - several weeks, maybe more.

2 Likes

Same issue here. I can have a reliably sync chain on my OSX and Windows machine. IOS devices (iPhone12 Pro and iPad Mini) freeze or crash trying to join via QR code, and via words they will sync ONCE and only ONCE

I’ve decided since its been a long time with zero resolution to give up on Brave mobile, I export my bookmarks semiregularly on OSX back to Safari, lets those sync into iCloud and show up on my mobile machines.

2 Likes

Exactly same problem on my iphone and ipad, ios 15.2 i think (recent one), started around month ago, bookmarks are dead after initial sync, sync settings keep kicking me off after killing and starting brave app, but device is still on the list of synced devices

3 Likes

Hi, just a little message to add my voice to this thread.
I have the same problem with iphone 11, ios up to date.

1 Like