iOS Sync Won't Work "Sync Communication Error"

Problem Description:

I have successfully been able to start a sync chain between my laptop and desktop which run Windows 10 as an operating systems. When I try to add my iPhone to the sync chain however, it shows the next screen and then immediately backs out to settings. After some time a dialog box opens with the title “Sync Communication Error” with the description reading “The Sync Agent is currently offline or not reachable. Please try again later.”

I have exhausted every avenue that I can think of to fix this on my own. Can someone from the community please help? I can provide pictures/video of the problem upon request. I would just need to obscure the private information contained within the QR code/Words.

Things I have tried:

  • QR code and text based methods to add my phone to the chain

  • Restarting the browser

  • Restarting the phone

  • Restarting my computer

  • Updating to iOS 15.01

  • Updating Brave in the app store

  • Updating Brave on my computer

  • Adding while on WiFi

  • Adding while on my cellular network

  • Trying at different times of day/week

  • Looking through my iPhone settings to see if some privacy/security feature was blocking communication.

  • Looking on Brave’s support documentation

  • Looking on Reddit and Brave Community forums for a similar issue (Only found Android related problems)

Devices info:

Model: iPhone 11 Pro Max
iOS Version: 15.01
Brave Version (PHONE): 1.31.1 (

Edition: Windows 10 Pro
Version: 21H1
OS Build: 19043.1266
Experience: Windows Feature Experience Pack 120.2212.3920.0
Brave Version (COMPUTER): 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)



I have the same issue:
the sync on IOS version stops to work.

Just like reported by @user423379 I discover this when going into settings > sync: the screen briefly (half a second) shows the sync, then goes back to the setting main page.
I don’t have an error message (unlike @user423379)

After this behavior, if I go back to settings > sync, then the app offers me to join a sync chain or start a new one: the previous sync is gone for good like it never existed.

I tried the same things @user423379 reported, and in addition to those, I tried to remove/reinstall the IOS app.
In spite of all this, the issue is still not fixed.

I can report the sync on my chain however to work fine with Brave installed on Windows 10 and macOS: only the IOS doesn’t stick in the sync chain.

I can replicate the issue:
if at day 1 I make the IOS join the sync chain, then the next day when going into settings > sync, this behavior described above happens.

I am also on IOS and I have the feeling that the sync was working very well in previous version (ie: version

I hope this thread gets a bit more response and attention so this can be resolved.

1 Like

Same I am having the same problem here and I cant sync on my compute |
Windows 10 Pro

broooooo i have the same problem just right now
tf is wrong with brave
i have alot of important stuff that i need to make on my laptop

1 Like

I have the same issue. Following for resolution.

1 Like

I get this too.

Also get sync not even working on iOS anymore as it connects but instantly stops syncing, and I often get this error message.

Sync seems really broken lately.


Same issue here on Iphone 12 iOS 15.0.2 but it did work on my 6th gen Ipad iOS 14.6

Same here: fresh install of Brave
Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit)
on Linux desktop and trying to sync with iPhone - doesn’t work. If I start the sync chain on the phone then I can sync to the desktop. Adding another iPhone to the chain by scanning code from desktop fails.

I am having the same issue on an iPhone

Yep. Brave Sync has been broken on iOS for months now. I do hope someone actually reads these posts. Cause replicating this is dead easy. I’ve already experienced 3 different iPadOS updates and none of them fixed it.

How to replicate the sync issue? Just install brave on iPadOS, latest official version. Set your settings. Go to Sync. Join an existing chain. Enter the code phrase. Boom, you joined, everything works perfectly. Come back in a few days. You realise you’re out of sync. Try to fix it by going to Sync again from the menu. Brave crashes. You open it again, boom. It prompts you to either join a sync chain or create a new one. So, the device has dropped out of the sync chain. P.s. other devices on that sync chain include a Windows device, a Macbook Pro one and an Android.

Those were the exact same steps to replicate the issue for months now.

Thanks @Murtadha, I fully concur to your statement and steps to replicate the issue with 100% chance of replication success.

I’m growing uncomfortable knowing that this has been posted since months and has not got any attention from key people at Brave.

Does anyone here knows of a way to drag Brave’s attention to this? Or at least get acknowledgement that this is in their radar (with whichever priority they decide to attach)?


Same issue. How come no one from Brave has responded?

Same issue here. Keeping the thread alive

iOS Sync issues already being kept alive in this thread:

Suggest continue there. Has more information and posters are posting scenarios and updates as they get them.

I am getting the same issue when I try to create a Sync Chain between my iPad and Win 11 laptop.