Brave sync on iOS is completely broken and has been for many months! - plus other bugs with sync on iOS too. (iOS) If you have iOS please read!

i got some success here;

i started my sync chain on iOS then linked the other devices to it and its been working ok, for now.

1 Like

I have all 3 of these issues (and more).

  1. My iPhone 12 Pro Max doesn’t sync except when you first join the sync chain - Exactly as your Issue No.1
  2. My iPhone is extremely difficult to remove from my sync chain with my 2 other devices (Macbook Pro & Windows 10 Pro PC), it looks like you have left the sync chain on the iPhone, but it’s still in the sync chain on the other 2 devices - definitely same as your issue No.2
  3. My iPhone locks up when trying to join a sync chain - if you try and use QR Code it freezes and locks up on the camera screen; if you manually key in code and click OK it then actually crashes and boots you out of sync & settings screens back to browser tabs, in one instance it crashed Brave completely, in another it reported sync server unavailable - definitely your issue No.3 (but with variations)
  4. When I do get my iPhone out of the sync chain on all devices (eventually) it will sometimes automatically reappear a couple of minutes later - but only on the other devices! This is related to issue No.2 but may be a separate bug - so lets say possible Issue No.4
  5. My iPhone also can’t get to the brave://sync-internals page - I just get search engine results when I enter it in the address bar and can’t find any FAQ info on if there is a special way to access on mobile or iOS app version of Brave - not sure if genuine bug or if I am doing something wrong. I have posted a separate thread asking about this under sync. Potentially an Issue No.5 for iOS devices if a genuine bug.

I am actually getting to the state of reverting to Safari on my iOS/MacOS devices (especially given Safari’s recent updates) and conceding privacy and syncing with Google Chrome on PC as this issue is getting extremely frustrating and tiresome (and along with the unable to save PDF one I posted about elsewhere is making Brave a bit undesirable).

I actually have 4 devices; iPhone 12 Pro Max (iOS 15) Macbook Pro 14 (2021 model with MacOS/OSX) & a Windows 10 Pro PC, but due to the iOS Sync Chain Issues I have stopped even thinking about trying to add my 4th device (an older iOS iPad Mini 2) that I use occasionally to my chain as a result.

2 Likes

Yup all the exact same as you, just with an iPhone 12 rather than 12 Pro Max. Now on iOS 15.2, and whatever the latest Brave version is (automatic updates are turned on for my phone and App Store). I have already gone back to Safari and enjoy using its Private Relay feature. I continue to use Brave on PC for now, in the hopes this will be resolved, but if it’s not by the next time I’m seriously inconvenienced by how broken Brave Sync is, I may just return to Firefox (not a fan of its UI on iOS, but at least syncing works).

BTW I too just get search results when trying to visit that page, so IDK what’s up.

2 Likes

The new safari is probably far better than Firefox on iOS and you can sync it with Firefox on PC via iCloud for PC. Only annoying thing with Firefox on PC is it’s terrible for composing emails in Gmail.

Anyway like you I am starting to plan on probably ditching Brave if this issue is note resolved ASAP after New Years - and will do the Safari/Firefox combo (3 Apple Devices using Safari and 1 PC with Firefox).

As of today (Christmas Day in NZ) I am continuing to have the same issues…

1 Like

Yea very very frustrating you cannot get to brave://sync-internal in Brave on iOS as this has a key tool you can use to try and reset the syncing…

1 Like

Maybe it’s too early, but yesterday I updated brave on iphone and ipad and it seems working well still, so fingers crossed that it’s fixed, i get all bookmarks well synced again

1 Like

Please keep us informed, this is good news if so!

Problem solved (at least temporarily). Delete Brave from all iOS devices and then reinstall from the App Store. Go through all the settings and options to get it back to the way you want it then set up sync. It worked for me.

Selection_006

my thoughts that i might of solved the problem where short lived, as you can see from the screenshot my ipad is out of syc already even though ive just been using the browser today (26th)
i don’t get this problem with Firefox on iOS so i’ll leave the browser for a few months and get back to enjoying surfing the web

1 Like

I see that I am not alone with this problem! I don’t follow this site too often! I have the exact same problem as everyone else here and I have a Mac w/ a iPad and iPhone attached to my sync chain and my IOS Devices refuse to Sync after the initial Sync after attachment. And I have tried all the things suggested here in the past and nothing!

1 Like

Have you retested syncing after a day or so? It always works when you initially join sync chain and sync (no need to uninstall and reinstall, just leave sync chain then rejoin) - its whether it’s still syncing hours or days later when you make changes or add new bookmarks, history, etc…

So - update from my side - On Christmas Day evening I have reset the sync (i.e. left and rejoined) on my iPhone, and also added my old iPad Mini to the sync chain at that time as well, so it’s now been 2½ days. I have these 4 devices on the sync chain:

  • Windows 10 Pro PC (O/S 19042.1415 - Brave 1.33.106 Chromium: 96.0.4664.110 (64-bit)
  • MacBook Pro 14 2021 (MacOS 12.0.1 Monterey - Brave 1.32.115 Chromium: 96.0.4664.93 (Arm64)
  • iPhone 12 Pro Max (iOS 15.1.1 - Brave 1.33 (21.12.14.16) EDIT: Note I discovered Brave had auto-updated this morning to the version listed, it was released about 4 days ago.
  • iPad Mini 2 (iOS 12.5.4 - Brave 1.24 (21.4.1.15)

First up the older iPad Mini 2 with older software and Brave version did sync okay when initially added to the Chain. So the older iOS and Brave versions didn’t impact that.

Syncing between the PC and MacBook works fine and is instantaneous when new bookmarks are added. History also appears to sync successfully.

The iPad Mini 2 running the older versions of iOS and Brave also syncs successfully and instantaneously - indicating a work around is to go back to an older version of Brave (e.g. 1.24) on iOS devices.

The iPhone 12 Pro Max (on latest Brave and iOS) has not synced either Bookmarks or history since Christmas Day so its clearly an issue with the latest version of Brave, or less likely iOS 15.

I am going to try to roll back Brave on the iPhone (if older installs are available for iOS). And verify if syncing now works with an older install.

If that fails I will ditch Brave and revert to the new Safari, and sync via iCloud to FIrefox on the PC.

P.S. I think Brave needs to be rolled back to version 1.32 which is about 2 months or so old and is the last one that supported iOS 13 (and had some bugs with iOS 15 fixed in it). Just need to figure out how to force this older version onto an iOS 15 device…

EDIT / UPDATE:

@Fellwalker57 might actually be onto something - as may have picked up the newest version as part of the uninstall/reinstall - so while I try to see how to install an older version I have followed their example and deleted app and reinstalled.

Immediate Thing I have noticed is my iPhone did not lock up when it scanned the QR code, it did this successfully and joined my existing sync chain and updated instantly - so something has definitely changed (but there is no reference to sync in the update notes for 1.33).

My iPhone 12 Pro Max is reporting Brave version 1.33 (21.12.14.16) same as earlier (see post above) but I did not try a sync rejoin before app reinstall unfortunately. I will update this post with edits once I test sync a bit more on it over the day.

EDIT / UPDATE 2:

1 Hour on and iPhone is still syncing…

I have also done several updates on O/S and Brave so all are the latest version available (changes in bold) - so device versions are now:

  • Windows 10 Pro PC (O/S 19042.1415 - Brave 1.33.106 Chromium: 96.0.4664.110 (64-bit)
  • MacBook Pro 14 2021 (MacOS 12.1 Monterey - Brave 1.33.106 Chromium: 96.0.4664.110 (Arm64)
  • iPhone 12 Pro Max (iOS 15.2 - Reinstalled Brave 1.33 (21.12.14.16)
  • iPad Mini 2 (iOS 12.5.5 - Brave 1.24 (21.4.1.15)

Just tested it now, 24 hours after reinstalling, and sync works. However, I would not be at all surprised it if fails tomorrow!

1 Like

Fingers Crossed. I will keep monitoring mine today/tomorrow also. :thinking:

It may be the dev team have resolved the issue in 1.33 but haven’t mentioned that as they would need to acknowledge the original bug which I am not aware of…?

EDIT / UPDATE 3:

4 Hours on and iPhone and iPad Mini are both still syncing okay.

Update: 24 Hours in and Sync has broken again - but only on iPhone 12 Pro Max, and NOT on my older iPad Mini 2 (the later is still syncing okay). PC & Macbook both syncing fine.

iPhone 12 Pro Max (iOS 15.2 - Brave 1.33 (21.12.14.16)
iPad Mini 2 (iOS 12.5.5 - Brave 1.24 (21.4.1.15)

Think my original theory of reverting to Brave 1.32 on iOS 15 is the solution - but have not been able to find an easy way to do so as not possible in App Store… (by that I mean the original 1.32.0 from October, not the more recent incremental updates, or else revert to older 1.31.1 to be safer)

@Fellwalker57 if you are on IOS 15 presume you sync has now broken also?

I had constant problems with sync to a point I just gave up and went back to Firefox. Syncs perfectly with no weird out of sync issues or bugs whatsoever. And I have 4 devices, 3 PC’s and iPhone that sync and they are always synced perfectly. Last time I’ve seen so many sync issues was when Firefox got sync in the very beginning. And even then it wasn’t this bad. They’ve been fixing Brave sync for months if not years already and it’s still broken and something you just can’t rely on. I just don’t get it.

1 Like

Yep - just doesn’t make sense. It’s like the not being able to save a PDF to your local iOS files - you have to copy the link to Safari (or ANY other browser for that matter) and do it from there - or to do it from Brave you have to do it to Dropbox, OneDrive or Google Drive - you can’t do it to the iOS devices native File location or iCloud?? At random times the function seems to appear then next time or go to do it it’s not there - so obviously very transient conditions for when it actually works… Sync appears to have the exact same behaviour…

I do wonder if due to the bitcoin and similar focus Brave has, development for iOS (unlike most other developers) is a very very poor cousin for development and all focus is on Android and such like.

1 Like

So after a couple of days sync is only partially working. I added a bookmark on iOS Brave and can see it on macOS Brave but not on my other iOS device.
I have other Brave problems which are ALWAYS solved by switching to Safari. If Safari supported the extensions I use on Brave I’d probably switch permanently.

2 Likes

Still trying to figure out how to ‘roll back’ Brave on iOS 15 from 1.33 to 1.32 or 1.31.1? Anyone got any suggestions on how to do this easily on an iPhone without jailbreaking, etc (as you can’t do it directly through the App Store)?

Essentially it’s a rollback of 5 or 6 versions (1.33 current, 1.32.3, 1.32.2, 1.32.1, 1.32, 1.31.1).