Brave for iOS doesn't sync bookmarks

I have Brave installed on 3 computers and my iPhone 11. Everyone is in the same Brave Sync Chain. So everything gets synced for PCs but iOS does’t receive new bookmarks.

So, when I created a Sync Chain Brave iOS downloaded all my bookmarks. But after that if I create new bookmark on any PC - Brave iOS doesn’t receive it. And in Sync Options on PC it’s showed that Brave iOS was active 2 days ago even when I was using it several times this days.

I tried to completely recreate Sync Chain, tried to reinstall Brave iOS, no success.

Steps to Reproduce:

  1. Create Sync Chain with your PCs and iOS device;
  2. After sync create new bookmark on any your PC;
  3. This new bookmark won’t appear on Brave iOS.

Reproduces every time for several days.

Brave Version:
Brave PC: 1.33.106 Chromium: 96.0.4664.110
Brave iOS: 1.32.3 (

Type of devices currently running on the Sync chain in question:
iPhone 11 with iOS 15.2
PC with Manjaro Linux (Testing Branch) x2
PC with WIndows 10 19043.1288

Additional Information:
Some screenshots. I created testing bookmark folder on my PC:

Then my iOS device is in Sync Chain but it’s not active for 2 days, but I was using Brave iOS:

And after that - no test folder on my iOS device:

1 Like

Yep, Brave sync has been broken for a good long while now if you use iOS, and so far there’s been one response and nothing done to address the issue, just seems we’re being ignored. Ironic, since iOS is such a huge market and iPhone users may be more privacy-conscious (at least nowadays) and thus more likely to use Brave…

Oldest thread I know of regarding Brave sync on iOS. It’s been broken for over a month.

1 Like

Been having the same problems MacOS Monterey/iPad Pro/iPhone for quite a while now - several weeks, maybe more.