Brave Sync Issues Between Windows and iOS Devices

Description of the issue:

I’ve been enjoying Brave for a little bit but now the bookmark thing is killing me. In fact it seems to stem mainly from iOS. If you create them from iOS first, this seems to be when issues arise. I finally gave up and killed all of my devices in the chain on all my systems. Then I started over and created it from my Windows 10 laptop. I added my iOS phone and i thought it worked, however no syncing actually occurs, nothing…I didn’t know why until today.

I added a completely new iOS device that has never been apart of my sync chain and this is what I got, view pic. I have no idea how to recover from this as i’m unable to eradicate the entire sync chain that has somehow duplicated itself. Any help in wiping the entire slate clean from support would be most appreciated. I added a pic of my other systems as well to show you what i’m seeing.

How can this issue be reproduced?*

I am not really sure how to reproduce this issue. It seems like i can just clean all my sync devices, Windows and iOS and start over but I always end up in the same place. So for me recreating it can simply be done by removing all devices and creating a new sync chain from either OS.

The best part is i have a Lenovo-Laptop in the sync chain but when i go to that computer, there is no sync chain available, just the question, “Start a new sync chain?” It’s like i have a twin brother with identical hardware and my entire sync chain is duplicated. How can i fix this as just deleting devices and sync chains is not working at all.

Expected result:
I want to have 1 clean sync chain that actually works.

Brave Version( check About Brave):
iOS iPad Air 3: 1.13 (19.11.06.18)
iOS iPhone: 1.13 (19.11.06.18)
Mac Book Air: 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)
Windows 10: 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)

Mobile Device details
Newest iPad Air 3
iPhone Xs Max

Additional Information:

iPad Pic:

iPhone Pic:

Mac Book Air Pic:

When you restarted the sync chain did you create a brand new chain or re-use an existing one?

Created a brand new sync chain.

I love it, no one knows or cares to try and help me solve this sync duplication issue, thanks Brave Support Team!

Looking into this further I have tried deleting any device on the duplicated sync chain using my iPad, the only device that is new to the entire sync chain. It seems to be the only device that has identified the duplicated sync chain. When i try to delete a device the Brave browser crashes. I then reopen the browser and try a different device in the duplicated sync chain, crashes again. Something is horribly wrong with my sync environment. I wash i could just find wherever this stuff is stored in whatever config file and delete everything and simply start over but i can’t because the duplicated sync chain won’t go away.