Repeated Unexpected Immediate Closure of Brave Browser Application on New Mac

Hello all! I recently purchased the new MacBook Pro and am currently in the act of installing all of the applications from my previous Mac. I have been a user of Brave Browser for at least a year on another account, thoroughly enjoying the experience the browser provided whilst racking up 500k ads + trackers blocked, 7 hours of ad blocking, and 9 GB’s of data saved. To install Brave on my new Mac, I went to the download brave portal on, and selected the correct version of Brave in accordance to my MacBook chip. The download went smoothly, but when I tried to open the application, it would close automatically. My MacBook displayed the notification “Brave Browser closed unexpectedly. Would you like to anonymously report this issue to apple?” I tried opening it five more times to no avail, with the application closing unexpectedly immediately after opening. I uninstalled Brave, refreshed the webpage, and redownloaded the correct version. Again, the download went smoothly, but the issue with unexpected immediate closures continued to occur. I decided to restart my computer, clear my Safari history, load up the webpage, and download the correct version. Again, the download went smoothly, but I was unable to open Brave due to its immediate closure. I expected the software to run smoothly, as I had no issues with it on my old computer, so I am confused by this result.

I am on macOS Monterey 12.2.1, up to date on the new MacBook Pro 14-inch released in 2021 with an Apple M1 Pro Chip, and 16 GB’s of memory. I am unable to see the Brave version I downloaded, but I do know that it is the most recent due to the fact that I downloaded it off of the Brave website and that it is meant to be used with M1 chip computers. Could anyone offer information on the root of this problem and steps I can take to resolve this minimal malfunction? I thoroughly enjoyed using Brave and would like to continue using the application with no speed bumps. Any advice is greatly appreciated, thank you all!

  • keeganmark

If you are still experiencing this problem, I linked some posts from other topics with this issue that worked for those community members. I myself know nothing about macOS but hopefully these links help.

Please note, the below solution reinstalled Brave Browser from GitHub. Apparently, you do not have to do this.

Another link in case you need.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.