Brave crashes upon launch on brand new M1 iMac 12.1

I have this exact problem, I’ve downloaded both packages from the Brave website:
Brave-Browser-arm64-XWV588.pkg
Brave-Browser-arm64.dmg

It installs with absolutely No issues, but when you try to open it crashes immediately generating the report shown above.

Please help!

I have the exact same problem. It will crash upon opening. The only difference is that I am on Big Sur 11.6.2

same issue, different machine. using 14’’ MBP M1Pro chip, downloads no issues, immediately produces crash report. this is both with the official release and the beta release of brave, please help!

Can you check — with the browser installed — to see if you have Brave Software folder in your Application support directory?

Users/[your user name]/Library/Application support/

I still have the same issue and i dont have this folder.

@ZiG-ZaG,
Can you please try downloading and installing the latest version of the browser from our Github directly? Use the link below and select the Brave-Browser-arm64.pkg option:

@Mattches I don’t have the folder within the user library either, I uninstalled Brave, restarted Mac, ensured again the folder is not within my user library, then used the GitHub link to download the Brave-Browser-arm64.pkg, the same issue persists. upon opening Brave the app crashes with a crash report

Same here. I Downloaded the file, installed it and after starting it crashes immediately. On the Other hand, I have no Library Folder where you ask it to be.

Under User (Benutzer) is no Library Folder, but as you can see on the picture no Brave Folder at all.

jelacou

Understanding the Apple (Mac) Operating System Crash Report:

ZiG-ZaG

Thanks, that really works.
I made the Library Folder visible and then deleted the BraveSoftware Folder.
Now Brave starts without Problems.

Thanks.

1 Like

The solution to this problem was exactly that, steps I took:

  1. Downloaded the package directly from Git
  2. Installed the Software
  3. Went into User>Library (it’s a hidden folder)
  4. Deleted the BraveSoftware folder
  5. Relaunched Brave and it worked normally.
4 Likes

after multiple failed attempts, the issue was resolved with the method above that CiscoCampos detailed in steps, the only other step I had to do was remove the folder from the system library and then restart my Mac

1 Like

@ZiG-ZaG , @Mattches

Some of the “Brave crashes upon launch” of late, may be related to that dmg installer:

PS. Good to know that the pkg installer survives installation.

Otherwise, both @ZiG-ZaG and @CiscoCampos have both discovered that there is something within the “BraveSoftware” folder:

/Users/user_shortname/Library/Application Support/BraveSoftware/

that is probably causing the “crash at/after launch” problem. A possible cause (my guess for the moment), is:

“chrome-extension://mnojpmjdmbbfmejpflffifhffcmidifd”

located here:

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/Default/Local Extension Settings/mnojpmjdmbbfmejpflffifhffcmidifd

because

source: chrome-extension://mnojpmjdmbbfmejpflffifhffcmidifd/out/brave_extension_background.bundle.js

is throwing a lot of errors (showing up in the Mac OS Console):

Frequent Crashing, MacOS Monterey, M1 - #10 by 289wk

And there, Mattches has a request for users who experience the crashes, to set their Brave Browsers to automatically send diagnostic reports:

Frequent Crashing, MacOS Monterey, M1 - #11 by Mattches

On my side I did only this steps:

  • delete the Users/[your user name]/Library/Application support/BraveSoftware folder
  • relaunch Brave

and it worked.

I didn’t uninstall Brave, nor downloaded it from Github.
The BraveSoftware folder is recreated when Brave is started, but does not prevent Brave to start anymore.

(You may need to enable the display of the Library folder in Finder layout menu.)

1 Like

Yes, I think that’s all that was needed. I did, however, redownload from brave.com before I saw your post.

How do I access this file? I can’t see it through finder… Could someone provide cmd line steps?

By default, the Library folder is not visible, you need to enable an option in Finder layout menu to make it visible.

maybe that helps to make the folder visible

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.