NOTICE: Unexplained Data Loss Issue

Hello Community

(note that issue is not related to Rewards)

We have noticed a significant uptick in user reports concerning a random/unexplained loss of data in the browser. Based on these reports, it appears that the data in question can be anything stored locally/in the browser — from passwords, to bookmarks, to all browser profile data. I have left a list of some example reports below for reference.

Reports of data loss

Brave Browser Bug - #5 by Mattches
Randomly lost all of my saved passwords - #3 by geluk
After Brave Crash, lost all passwords - #2 by Mattches
50 bookmarks VANISH - #2 by Saoiray
Everything got reset except saved passwords and bookmarks on Windows update - #2 by Mattches
Lost saved passwords (and log on cookies ?) - #2 by Mattches
Leaving Brave soon - #5 by Frank19335
Lost all saved passwords after PC crashed
Brave removed ALL my saved passwords - #6 by Mattches
Lost all my data - #11 by SmartyAadi
Lost all my data - #2 by SmartyAadi
Saved passwords disappeared and password Manager won't save new ones
Brave crash, lost passwords
Data disappeared
Reason for disappearance of stored login info - #7 by Saoiray
Passwords Lost wtf - #4 by Mattches
All my password data was deleted during update

I wanted to update you all on the status of this issue and assure you that our developers are actively looking into it.

Issue is likely Chromium based

This issue appears to be inherited from the underlying Chromium engine, rather than something that is specific to Brave and you can see similar examples of this happening on Chrome and other browsers as well.

How does this get fixed then?

As this is an important issue, rather than waiting for a fix to come from upstream (as we often do with Chromium based issues), we are attempting to see if this is something that is within our scope to fix ourselves. Note that this is a non-trivial issue and a rather large undertaking and may take some time. You can read more about this in the “Advanced reading” section below.

Actions users can take to help

If you have encountered this issue, where data in your browser has seemingly mysteriously disappeared, first please confirm the following:

  • You are not accidentally using a different/separate browser profile than you normally do
  • You did not accidentally clear any relevant browsing data via brave://settings/clearBrowserData, nor do you have this data set to be cleared “On exit”
  • You did not recently change your system password or have it forcibly changed via an administrator (Windows users only)

Any of the above scenarios would explain why you no longer see your data in your browser.

However, if the above does not apply to you and your passwords (or other data) seem to have randomly disappeared from the browser (for example, you shut your computer down for the night and when launching Brave the next morning, your data isn’t present), below are some steps you can take to help us help you.

We will use this thread to gather information on this issue for the developers to review. If you have encountered this issue, please respond to this thread with the as much of the following information as you can provide.

Basic data to gather
  • What OS are you using where the issue occurred (be as specific as possible, eg Win 10, Win 11, macOS Ventura v13.3.1)?

  • For macOS users, verify that Brave has access to the system keychain by going opening Keychain Access on your system, clicking the Login tab on the left and ensure that Brave safe storage is listed here.

  • What Brave version you have installed (you can view this by opening the browser and going to About Brave)

  • When/how/what actions were taken when the data loss occurred (eg, Did the browser crash? Did this occur after a system restart? Did this occur after an update? etc.)

  • If the issue did occur after a crash, providing us with the crash report ID would be helpful (you can do this by going to brave://crashes and sharing the crash report ID left under the event)

  • Please tell us exactly what data was lost (was it just passwords? Passwords and bookmarks? All data? etc.).

  • Are you using a password manager extension? If so, is Offer to save passwords enabled?

  • Are you using Brave Sync?

    • If so, can you please check and see if the other machines/devices on the chain have this login data saved/intact still?
Advanced Reading

Brave uses Chromium and doesn’t have any deviations in the code with regards to saving logins. The logins are saved to the Login Data file inside the profile folder and the password field is encrypted using an internal (to Chromium) library called OSCrypt. When OSCrypt fails to decrypt the password, it won’t show the entry in brave://settings/passwords. However, you can use a SQLite editor like DB Browser for SQLite to open the Login Data file and you’ll see the logins in there (with password being encrypted).There are a few ways where you can run into a situation where OSCrypt fails to decrypt the password and it looks like the logins were lost.

  1. If you copy your files from one machine to another, you won’t be able to access those decrypted passwords (you should use sync instead)
  2. If your password is forcibly changed by an administrator. You might be able to change your password to what it was before to resolve the problem.
  3. If you deny access to Keychain when it asks you (macOS) when launching Brave. It needs that access to encrypt/decrypt.

When these cases happen, a new key is created meaning you can’t decode the entries that were encrypted with the old key. The key and the encryption are OS specific. macOS stores the secret in Keychain and you need to grant access for Brave to access keychain to store and read this secret, otherwise you can’t decrypt the passwords for a login.We’ve looked at the code and having found anything obvious - we don’t have any changes to logins, we’re just using the Chromium code. We know that Chrome and Chromium users experience this too and we’re still trying to understand the reasons how the key can change.

Advanced data to gather

(note that the information below pertains primarily to loss of password/login data)

  • Histograms information can be very helpful for us — you can find this information by going to brave://histograms/OSCrypt and clicking the Download button. If you have these data, please simply say (in your reply) “I have histograms to share” and I will DM you so that they can be sent securely.

  • It can be very helpful to know whether or not Login data (where passwords and login data are stored) still holds your information information and it simply isn’t being decrypted, or if it’s just blank and the data has been fully cleared. Note that the Login data file is an SQLite file and requires a SQLite DB viewer to view properly. If you do not have one, I would recommend this one as it is free and easy to use. To check if your data is present:

For Windows users you can locate your Login data file by going to:
C:Users\[your user name]\AppData\Local\Brave Software\Brave-Browser\User Data\Default

For macOS users you’ll find it in
~/Users/[your user name]/Library/"Application Support"/Brave Software/Brave-Browser/Default

For Linux users you’ll find it in
~/.config/Brave-browser/User data/Default

Once your Login data file is located, open the file using your SQLite viewer and confirm whether or not your data is still present here.

We do appreciate everyone’s patience and understanding here and hope to have a solution to this issue as soon as possible. If anyone sees a Community member reporting this issue, please direct them to this thread.

Thank you


Operating System: openSUSE Tumbleweed 20230503
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Kernel Version: 6.3.1-1-default (64-bit)
Graphics Platform: X11
Processors: 20 × 12th Gen Intel® Core™ i7-12700
Memory: 31.1 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
Manufacturer: Dell Inc.
Product Name: XPS 8950

This broke after the latest update of brave-browser from the repository. It also broke on my laptop running the same versions of software. No crash involved.

I was able to downgrade the package by running the following.

sudo zypper install --oldpackage brave-browser-1.50.125-1.x86_64

This allowed me the chance to add the Sync Code. Since both devices were broken, I had no access to the Sync Code. One from a text file said it was expired. I had a 6 month old Acronis image of the laptop and installed that to put Windows 11 on it and grabbed the Sync Code from there. It worked. I now have a fresh text file of the Sync Code and can try to help out here for everyone else’s benefit.

Now that it is working on the desktop, it was still running version 1.50.125-1, but everything was normal again. I ran a zypper dup and installed the new brave-browser and it immediately broke it.

Doing some checks as you asked.

History seems to be there.
Bookmarks seem to be there.
Passwords are missing.
Offer to save passwords is on. No external password manager installed.

I cannot check anything on the laptop now, since I had to re-image it to get the old Sync Code from Windows. I will just do a fresh install of openSUSE after this is over. I have a full back up of my /home files.

I grabbed the histograms, but it is only 11 lines long and appears to be useless in this case.

1 Like

I am willing to do the “brave://settings/clearBrowserData” and input the Sync Code to test it, since I now have that code available.

I was just doing a bit of digging. It appears that Form Data is still there. Cached Images and Files still appear to be there. At least some cookies appear to be there.

Out of curiosity, I ran the command to brave://settings/clearBrowserData and deleted the data. It still won’t allow me to put in the Sync Code. I think this part is a big clue.

Once I completed my testing, I used sudo zypper install --oldpackage brave-browser-1.50.125-1.x86_64 to downgrade to the version that worked. I put in the working Sync Code and all was good. I did not have to do anything with the kdewallet manager. Now that I have the previous version working, I disabled the Brave repository until this all gets sorted out. Hopefully, that won’t take too long.

The big part to a temporary fix is having that Sync Code available.

Description of the issue:
a few hours ago I closed my browser and opened after an hour
i saw my browser site’s data’s and my other profiles are gone
only user 1 the main profile remains with bookmarks, browsing history data’s but all sites data’s are gone on the profile too

Then I look in to the local app data folder to see is it deleted or still the files remains
in C:\Users\AppData\Local\BraveSoftware\Brave-Browser\User Data
nothing is deleted i guess the other profiles folders and data’s are still there

but It’s not restoring to the browser . if i create a new profile on browser those are working but i want my old data back …

**Expected result:random data loss but files still remains i think

Brave Version( Release Notes v1.51.110 (May 3, 2023)`):

Additional Information:
OS : windows 10
confirmed that
did not change passwords ( usually i don’t save passwords in browser)
did not copy the profile from another machine
i don’t use any sync feature all are saved in my local files on pc

only brave and microsoft edge two browsers are installed on my pc


I have been trying to restore the data’s to browser
after all this What i did is created some new profiles …
and the new profile generated the new profile 1 , 2 , 3 folders … then i replaced the profile folder with my old profile folder … the data’s was restored on to the new profile but … the Site logins are not restoring this way … It’s means those old profile folders are still have my profile data’s

browser reinstalling also not fixing the problem :confused: is there any offline installer to degrade to old version ?

can you please tell me when the issue will be fixed? i saw many similar threads those are already few months older .
and can you tell me how i can restore those existing data’s ? its important i will lose my jobs

@ariyan779 Do you have the Sync Code?

I see the last good version on their GitHub.

A bit past 1/2 way down the page is Release v1.50.125 (Chromium 112.0.5615.165) and there is a Windows installer. I have Linux, but this is the version I used and it is working, but I had to put in the Sync Code to bring back all the passwords, etc.

When someone sets up the Sync for the first time, Brave needs to have a notice there that copying and pasting that code into a text file and keeping it safe can be their ONLY way to get their data back in the event of a disaster such as this. Even printed out on a piece of paper is better than losing all your stuff.

1 Like

I didn’t turned on Sync. so no sync code

Case 1:
OS: OpenSUSE/Tumbleweed [64-bit] updated today
Brave: Version 1.51.110 Chromium: 113.0.5672.77 (Official Build) (64-bit)

Today, I updated Tumbleweed which included Brave 1.51.110. After a reboot, following the update, I found that all the saved passwords were missing from brave://settings/passwords.

No password manager extension was used.
I have never used the Sync feature.

On this PC, Brave is usually invoked from a script with the following command line arguments:
exec /usr/bin/brave-browser-stable --password-store=kwallet5 --process-per-site --profile-directory='Default' "$@"

I used the sqlitebrowser program to view ~/.config/BraveSoftware/Brave-Browser/Default/Login Data and I found that all of the missing password entries were still in the database.

Case 2:
OS: OpenSUSE/Tumbleweed [64-bit] updated today
Brave: Version 1.51.110 Chromium: 113.0.5672.77 (Official Build) (64-bit)

I tried the same update on a second PC. On this PC, rather than doing a reboot after the update, I logged out, logged in again, and then restarted Brave. As with Case 1, all saved passwords went missing from the password manager page.

No password manager extension was used.
I have never used the Sync feature.

On this PC, Brave is invoked with the following command line:

I used the sqlitebrowser program to view ~/.config/BraveSoftware/Brave-Browser/Default/Login Data and I found that all of the missing password entries were still in the database.

Also, before updating this PC, I exported the Brave saved passwords to a file as a precaution. Then, after confirming that the update lost all of the saved passwords, I used the exported file to successfully restore the passwords.

Thank you, I greatly appreciate your efforts to resolve this issue.


May 6
Histograms: Yes
Sync: Never
Never set to delete data/cookies automatically
All passwords lost after this upgrade (on 8 computers!)
Only passwords are lost, not bookmarks. No error messages.
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-22-amd64
OS: Debian 11.7
Brave Browser Version: 1.51.110 AMD-64 installed May 4th
Actual path:- ~/.config/BraveSoftware/Brave-Browser/Default Note the “BraveSoftware” in the path unlike the example given earlier in this thread.
Example sizes (in bytes) and dates from one computer:-
163840 May 6 15:45 ‘Login Data’
49152 Apr 28 2022 ‘Login Data For Account’
0 Apr 28 2022 ‘Login Data For Account-journal’
0 May 6 15:45 ‘Login Data-journal’

Looking at “Login Data” in SQLBrowser shows missing password entries (though I can’t see the actual passwords)

Update: 10 May. Downgrading to Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit) solved the problem.

1 Like

For me Brave has no access to “safe system storage” and “sync”. I am running Arch Linux / KDE. Kdewallet is running fine and at starting new brave there was a question that Brave wants to access kdewallet - what I confirmed. But Brave does not access kdewallet. Bookmarks are accessible, but all passwords are inaccessible. Downgrade to Brave 1.50.125 makes all passwords accessible again.


I have got the same problem!
Ubuntu 23.04
KDE-Plasma 5.27.4
KDE Framework 5.104.0a
QT 5.15.8
Brave Browser 1.51.110

I installed the older version 1.50.125 and could access my passwords again, I exported the passwords and upgraded to version 1.51.110 again - after reimporting the passwords everything seems ok!

But where are the passwords stored now? The “Login Data” file has not changed after the import.

Still get the message “Brave could not access the secure storage of your operating system” when I start brave.

Tried to sync brave before but never had success with that.

1 Like
  • I am not accidentally using a different browser than usual and did not accidentally clear any data, not did I recently change my system password.
  • Windows 10
  • Brave is up to date [Version 1.51.110 Chromium: 113.0.5672.77 (Official Build) (64-bit)]
  • Problem occurred just over a week ago after updating to the previous version to this one I am on now.
  • Data being lost appears to be connected to my log in credentials for Uphold. The Uphold website (which I’ve used the same way for years) no longer remembers me and forces me to log in and complete 2FA over and over again. I am even being forced through an additional step of having to click on a link in an email before I can see my Dashboard. Uphold have been investigating for ages. So far as they are concerned, I am concerned and my ISP is concerned nothing has changed - only Brave updating so I am beginning to think this data loss issue might be the cause for my problems too?
  • I do not user VPN and the only extension I use is pw manager, which is enabled, and which I reset, cleared and relogged in but still having same issues.
  • I don’t use Brave Sync

Is fixed now in nightly build 1.53.x - I can confirm:

@df8oe — this issue is similar but the one you’ve linked to is specific to Linux systems.

@Thrive as stated before, this issue is not Uphold or Rewards related. Whatever you are seeing there is likely a separate issue entirely (unless you experienced more data loss than just your Uphold information/being logged out of sites).

…? Sorry I must have missed where this was stated before in relation to this particular problem which is not rewards or Uphold related I know, but I thought it might be browser related given I am being logged out of from viewing my Uphold dashboard on the Uphold website repeatedly each day - as if the cookie data is not being saved, and I am not the only Brave user who suddenly got this problem. I guess @Tidyyy and I are on our own then. Thanks. :cry:

I’m using Manjaro linux
I switched off my laptop before going to sleep, switched it on now and all sites are telling me to sign in.

All sites data are still available when i view permission and data stored across sites

In the local app data folder. I can see the Login Data, my login details are still there.

I didn’t change my password
I don’t use any sync stuff

I’m using brave Version 1.51.110 Chromium 113.0.5672.77 (Official Build) (64 bit)

Hi @grufo How can I downgrade to v1.50.125. on Manjaro linux? I tried using Arch Linux but it is not working.

@blackadam have a look at the github repo - there you can download all older versions!

you should be able to install the pkg file with pacman…

1 Like