Netflix not detecting widevine cdm


Description of the issue: Netflix does not detect widevine cdm even after accepting to install/run it
How can this issue be reproduced?

1.Navigate to www.netflix.com
2.Try to stream something
3.???
4.Profit

Expected result: Netflix recognizes widevine cdm

Brave Version( check About Brave):Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

**Additional Information: I tried to install widevine cdm multiple times, by creating new users. It does not work. **

1 Like

@HypnoFluffy,
Thanks for reaching out.
Can you check in Settings --> Extensions and ensure the Widevine option is toggled?

1 Like

Thanks for your reply, I just checked, the widevine option is on.

@HypnoFluffy,
Hmmm – can you try visiting another site that requires Widevine – Hulu or Spotify are commonly used – and see if those sites will prompt you to install Widevine?

I went to check on spotify, I did not get the prompt, and playback does not work. So I checked at brave://components, and sure enough, I do not have the widevine component. I’ll try making a new person on the browser and installing it via the prompt on the spotify website.

UPDATE: Just tried, and it doesn’t work either. I get the prompt, accept to install/run widevine, and then nothing.

Did you click Allow when you were prompted?

Yes, I clicked allow.

Are you on Windows 7 or Windows 10?
I was just able to do a fresh install of Brave (stable), navigate to netflix.com and receive the Widevine prompt without issue. After clicking allow, netflix refreshed and i was able to stream content.

What exactly does it do after you click Allow?

1 Like

@Mattches
I am on windows 10 Version 1809.

When I click allow, the page refreshes but it still does not work.

@HypnoFluffy,
Is it the screen informing you to install WV in order to stream?

@Mattches

Yeah, telling me to check for updates for WV

@HypnoFluffy,
Can you try clearing cache and site data for Netflix.com? Use the lock icon in the address bar --> Site settings --> Clear data – you may also want to Reset Permissions as well.

Then try refreshing and see if you’re prompted.

@Mattches
I just tried that, still the same problem. I’ll try restarting my PC, in case something bucked up with the install.

EDIT: Just restarted, still not working. I guess I’ll try a fresh install.

May be related to CR78, @HypnoFluffy are you on beta channel by any chance ?

Just tried a fresh install, still not working.

@sriram
If I am on beta channel, I’m unaware of it. How do I check?

It’s release channel, @sriram. :point_up:

SOLUTION: I did a fresh install, deleted browsing data, and logged back in. Got the prompt again, accepted and now it works. I think it might have something to do with CCleaner. It might have deleted some data that Brave needed.

2 Likes

@HypnoFluffy,
Great detective work – I was trying to avoid suggesting that as I’d prefer to avoid users deleting their browsing data just to get a component to function but I appreciate your initiative in doing so.

2 Likes

Thanks! Thank you for the support.

1 Like