Widevine not installed or being detected in MacOS Catalina 10.15 (resolved)

widevine is not in chrome://components/ and any website
netflix, hulu, amazon-prime, spotify etc … is prompting to install this extension.

Brave Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)
OS: MAC OS Catalina 10.15

I have

elabled
and I do not see any puzzle icon in the url bar when I visit these DRM websites.

I have uninstalled and re-installed brave multiple times, created new profiles multiple times.

Please suggest any solution.

These did not help at all:





There are more links, but I could not post. And then I stopped looking. Please help.

@ptewari See if the steps listed in this link help you solve the problem. https://support.brave.com/hc/en-us/articles/360023851591-How-do-I-view-DRM-protected-content-

Thanks for the reply but I already mentioned on my post that

I just noticed that you are using MacOS Catalina. I am still using Mojave and just went through the process outlined in that link to start watching netflix. (I have been using safari for all video streaming until now.) I know Catalina has not been the most elegant upgrade for Mac (buggy) so I have yet to upgrade. I will review the issue further.

I found a reddit article that claims to solve this problem for Catalina. Specifically states that it fixes widevine issues as well. Let me know if it works for you. https://www.reddit.com/r/MacOS/comments/c68gh9/solution_for_all_apps_not_opening_in_catalina/

I manually deleted to all Brave files in the Application Suuport folder in my ~/Library … I found 2 Application Support and ApplicationSupport (don’t know why there are 2 of these) and then disabled the spctl using the command sudo spctl --master-disable and then re-installed Brave. After opening Netflix, I got the DRM extension alert and then I went to the chrome://components and then updated the Widevine component. Now I can watch the video files. after this I enabled the security again sudo spctl --master-enable

Thanks!

2 Likes

Excellent! No problem. Feel free to drop back in if you have further issues. Happy streaming! :+1: