Netflix not working, even though it did some weeks ago

I had installed Widevine before, when asked by the browser, to see Netflix. But now somehow it doesn’t work and the browser is not asking for the plugin installation and I don’t know how to install it.
I tried deleting media licenses on Settings > advanced > clear browsing data > media licenses, but nothing changed and Brave is still not asking for Widevine. I also tried going to as pointed here Netflix and widewinecdm but the problem is the same: it doesn’t work and Brave doesn’t ask for any plugin on the URL bar nor anywhere.
My version is up to date: Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)

What can I do?

What operating system are you using?

Windows 10 home, version 1803. Also OS version 17134.472.

Can you tell me what does happen when you attempt to stream a Netflix video?

Video streams for 1 or 2 seconds, then error M7361-1253 appears. The solutions proposed for that error are restarting the computer and clearing browser cache.
Same Netflix video works in Chrome.

I already deleted Media licenses but nothing happened. Is there a way to uninstall Widevine so Brave asks me to reinstall it?

When you say

You mean you went to Settings --> Adv. --> Privacy and Security --> Content Settings --> Clear Browsing Data and cleared media licenses (just confirming, because this should have done what you’re looking for).

Can get and share a screenshot of the error message with me?

Yes, that’s what I did, except for “Content Settings”. The complete route is Settings --> Adv. --> Privacy and Security --> Clear Browsing Data --> Advanced --> Time range: All time --> Media licenses

This is a screenshot with just my sensible data hidden:

Good catch on the full-path typo I made above.
A couple things to try:

  1. You said that you’d cleared the media licenses data in settings. Confirm that when you attempt to clear Media Licenses, you set the time range to “All time”. If you’re willing, it may also be worth clearing your cache as well. There have been issues with cookie “artifacts” (so to speak) lingering around that cause errors that cease once cleared.
  2. Again, if you’re willing, we could test this further by attempting to login/visit Netflix while using a different Brave build. Try downloading and installing the Brave Beta or Developer build to your machine (I recommend Beta). Once done, visit Netflix and see if you’re able to access the site.
    Don’t worry, each Brave channel (Release, Beta, Dev) installs as a standalone application so none of your browsing data or information will be lost or overwritten.

Let me know if either of these work for you.

Ok, I deleted All time:

  • Cookies and other site data
  • Cached images and files
  • Content settings
  • Hosted app data
  • Media licenses

but still doesn’t work.

Also downloaded Brave Beta and went to Netflix. It asked me to install Widevine, I did it and it worked.
Went back to normal Release Brave to see if anything had changed, but still doesn’t work.
I’m thinking perhaps a full reinstall would work… but it’s kind of annoying to start again with a clean install and we would never know why the bug is there on the first place.

I have a question for you about this, do you happen to have Bitdefender installed by chance? I had the same issues as you and found out somehow Bitdefender blocks Widevine or Netflix/Hulu from working correctly. I have only had this issue while Bitdefender was installed, Devs might want to contact Bitdefender or figure out why it’s doing this. Netflix/Hulu and anything with Widevine installed works just fine without Bitdefender installed, I tried it with Kaspersky which I have now and it works just fine too. The Bitdefender behavior for me was I would install Brave, go to Netflix and it would work fine once I installed widevine but only for like the first session, once I would restart the computer, video would play for like 1 second then give an error code.


@agulab, can you confirm what @jktorres28 was asking about?

@jktorres28 was right!! I deactivated Bitdefender Protection Shield and Netflix worked on Brave.
Thanks a lot for your input JK, it’s great to finally trap the bug.
I’ll keep using another browser for Netflix until this gets fixed. Do you need me to report it somewhere else or this ticket is enough for developers to consider it a bug?

Thank you very much to both of you.

1 Like

@agulab, I’ll take it from there :slight_smile: