Widevine on Brave Browser

Issue: Can’t replicate message to install WidevineCdm

Procedure description:
First:

  1. Go to a page that requires WidevineCdm (in my case Netflix)
  2. Select never install in the popup and Never ask again

After that:

  1. I can’t play movies on Netflix (expected)
  2. On brave://settings/extensions Widevine is turned OFF
  3. No extensions installed on brave://extensions/
  4. Go to Netflix website and the message to install Widevine do not appear
  5. Notifications are ON
  6. On brave://settings/content/protectedContent is selected Sites can ask to play protected content

Question:
How can I replicate the message to install WidevineCdm?

Brave Browser version:
Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (x86_64)

Enabling Widevine via brave://settings/extensions should prompt for a Brave relaunch, after which the Widevine extension should be installed.

I already did that. I enabled Widevine via brave://settings/extensions and relaunch Brave browser. But I don’t see any Widevine extension installed on brave://extensions/.

Widevine should appear as a component at brave://components/.

You are right, is there, but if I disable Widevine on brave://settings/extensions and I try to login on Netflix I do not see the notification to install WidevineCdm. Notifications are ON for Netflix.

If Widevine is successfully installed, which looks like it, given you can find it at brave://components, I’m not sure you’re supposed to get such a message on Netflix.

Anyway, you could try resetting Netflix’s permissions, doing the following:

  1. Open Netflix.
  2. Click on the padlock icon in the address bar, it’s on the left side.
  3. Click on Site settings.
  4. Click on Reset permissions.
  5. Refresh Netflix.
1 Like

The situation is the following:

  1. Widevine is not installed because I disabled Widevine on brave://settings/extensions and I confirm that because I don’t find Widevine on brave://components.
  2. I opened Netflix
  3. I clicked on Site Settings
  4. I clicked on Reset Permissions
  5. I refreshed Netflix
  6. I don’t have any message to install WidevineCdm

If resetting permissions didn’t work, you could try after clearing the data.

  1. Open Netflix.
  2. Click on the padlock icon.
  3. Click on Site settings.
  4. Click on Clear data.
  5. Refresh Netflix.

Is there a specific reason you would like to install Widevine via Netflix rather than brave://settings/extensions?

  1. Open Netflix.
  2. Click on the padlock icon.
  3. Click on Site settings .
  4. Click on Clear data .
  5. Refresh Netflix.

I did that hours ago, but I did that again and still can’t get the message to install WidevineCdm.

Is there a specific reason you would like to install Widevine via Netflix rather than brave://settings/extensions ?

No reason in particular, but I like to understand what happened and if I understand how things works I should be able to replicate and maybe help others with some issues. In this particular case, the first time that I opened Netflix on Brave browser It ask me to install WidevineCdm and I selected Not Allow and Not ask again. Now i can’t replicate that. Any reason for that?

If you don’t mind clearing cookies, cache, and resetting all site permissions, you could try the following:

  1. Type brave://settings/clearBrowserData in the address bar.
  2. Go to Advanced.
  3. Preferably set Time range to All time.
  4. Check Cookies and other site data, Cached images and files, and Site and Shields Settings.

Note: there is a known and reported bug that clearing Site and Shields Settings browsing data resets the global Brave Shields settings, you’ll have to re-adjust the global Brave Shields settings at brave://shields.

Such prompts are normally related to site’s permissions, in Netflix’s case clearing the site settings via the padlock icon seems to not be enough, oddly enough.

P.S Searched around for similar threads, and it appears users have had problems re-triggering the Widevine prompt on Netflix, Spotify, and other similar platforms, so it’s not anything new to Brave. Might be an intermittent bug.

  1. Type brave://settings/clearBrowserData in the address bar.
  2. Go to Advanced .
  3. Preferably set Time range to All time .
  4. Check Cookies and other site data , Cached images and files , and Site and Shields Settings .

I do all of that when I close Brave.

Screen Shot 2021-07-24 at 21.49.51

On the image is not selected Site and Shields Settings, but I already tested having all selected.

P.S Searched around for similar threads, and it appears users have had problems re-triggering the Widevine prompt on Netflix, Spotify, and other similar platforms, so it’s not anything new to Brave. Might be an intermittent bug.

Agree. It seems to me that is a bug.

Being unable to re-trigger the prompt after clearing everything definitely sounds wrong.

@Mattches could you please take a look whenever you have the opportunity?

@Rethanis thank you for tagging me.
@filSec,
So what should happen is simply toggling Widevine CDM off/on in brave://settings/extensions, this should essentially disable then re-enable the component but I’m not actually sure if you’re supposed to see the installation prompt again since you had already previously.

What I would recommend is toggling Widevine “Off” then go to

Library/Application Support/BraveSoftware/Brave-Browser

and find the Widevinecdm directory here and delete it. Close and relaunch the browser, go back to Settings --> Extensions and enable the Widevine extension and see if it’s works as intended.

Widevinecdm always worked as intended. When I turn ON or OFF Widevine folder with name Widevinecdm appear and disappear respectively, from Library/Application Support/BraveSoftware/Brave-Browser.

The reason of my post is not that. The first time that I access to a website that needs Widevinecdm (in my case Netflix), Brave browser prompt me on the address bar to Allow or Not Allow the installation of Widevinecdm. I selected Not Allow and Not ask again . Now I can’t replicate that. How can I replicate that situation again?

@filSec,
Thank you for clarifying.
I think that the next step here is to test this using a new, temporary browser profile and see if you get the same results. Ensure you only have one browser window open (using the newly created profile) when performing the test.

@Mattches

I created a new profile called “test” and Bingo. With new profile I get the prompt.

The selected options are stored on profiles? Where are profiles stored on macOS? I don’t find any folder with my profile name on Library/Application Support/BraveSoftware/Brave-Browser!

@filSec,
So the Widevinecdm component data should be stored in Library/Application Support/BraveSoftware/Brave-Browser towards the bottom – not in the individual profile directories. You needn’t install a separate widevine component on each profile. What’s happening here seems to be a permissions hiccup.

Can you actually – on your original/main profile – try going to a different site that requires Widevine and see if you’re prompted there? Hulu and Spotify, for example, both require Widevine to run properly. You should also be prompted without having to login. Let me know and I will ask a few team members about the issue in the interim and see if anyone knows how to reverse the aciton.

@filSec,
Additionally, when you toggled the extension on/off in your main profile, did you relaunch the browser before attempting to visit Netflix again?

@filSec,
So I’m actually now curious about whether or not Netflix (or any site requiring Widevine content) works? If you have to toggle “on”, then you should be able to login and view content regardless of whether or not you selected block in the permissions prompt.

@Mattches

So the Widevinecdm component data should be stored in Library/Application Support/BraveSoftware/Brave-Browser towards the bottom – not in the individual profile directories. You needn’t install a separate widevine component on each profile. What’s happening here seems to be a permissions hiccup.

Yes, I see Widevine folder on Library/Application Support/BraveSoftware/Brave-Browser. However, I don’t see any folder with the name of my profile. Where can I find my profile? Is located in Library/Application Support/BraveSoftware/Brave-Browser/default?

Can you actually – on your original/main profile – try going to a different site that requires Widevine and see if you’re prompted there? Hulu and Spotify, for example, both require Widevine to run properly. You should also be prompted without having to login.

I went to Spotify with my main profile and I wasn’t prompted. Maybe because on Netfix I selected Do not ask again, right? However, Spotify tells me to secure playback, that is, to enable Widevine.