Widevinecdm PROBLEM! TOO HARD TO SOLVE!

I can’t watch movies on Netflix due to the widevinecdm is missing, and I had tried all the method on this site and none of them work! I opened spotify.com, primevideo.com,… but the widevinecdm still not promt! I love this browser but why the hell this problem is so hard to solve?

What is your Brave version, @weallgonadie?

@eljuno my brave version is: 0.67.125 Chromium: 76.0.3809.100 (Official Build) (64-bit)
Please help me with this!

@weallgonadie did steps describe here can help? https://support.brave.com/hc/en-us/articles/360023851591-How-do-I-view-DRM-protected-content-

Thanks but my problem is the puzze icon in the address bar for “missing plugin” does not appear. I tried other websites that need widevinecdm but the missing plugin icon still not show up. I’ve reinstall Brave but it doesn’t solve the problem

Thanks for the confirmation, @weallgonadie. Forgot to ask. What OS that you use?

The message seems shown as expected on my Windows machine – except it’s shown on different location.

im using window 10. I’ve checked “brave://components” and the Widevine Content Decryption Module - Version: 4.10.1440.18 does show up, it’s means i installed it when visiting netflix before. I click the Update button but nothing happen, and the Netflix still show error screen for missing widevinecdm :cry:

I’m having the exact same issue: can’t play something on Amazon Prime because I’m missing the Widevine cdm, and there is no puzzle icon. Also checked my brave://components and in my case it’s not even there; I recall being asked for it when I first started using Brave a few days ago, but I ignored it because I didn’t know why it was asking to install Widevine for a different, non-cdm site. I just can’t figure out how to fix this, though not for lack of trying. Deets:

Brave Version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)
Mac OS Mojave 10.14.6 (18G95)

I love Brave and really want to use it exclusively, but darn I wanna watch that LCD Soundsystem show right now (8:24am on a Friday)! :joy:

1 Like

I have also run into the WidevineCdm problem with both Netflix and Amazon Prime Video. Amazon says that I am missing a required “DRM component.”

When I search the Chrome extension store for WidevineCdm no extension is available.

Mac OS High Sierra 10.13.6
Brave Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

1 Like

Bro, seems like there’s no solution for our problem

Hey Brave admins: PLEASE HELP!

In Brave setting find Extensions>WideVine and enable “Ask when site wants to install widevine on your computer”

This option was turned on when i checked. I toggled it off and and on, restarted browser but i still don’t get the option to install Windevinecdm when i go to netflix. Any other suggestions?

@Akorita,
What OS are you using?

Hello. I’m using MacOS Catalina 10.15.1

Brave Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)

Hello guys
I think i solved the problem. You should turn on java script and flash on website you want to be. After that the asking about DRM should appear.
:slight_smile:

@hehe123 – Not sure I’ve ever heard of this particular solution but I’d give it a shot, @Akorita. Can you test and confirm whether or not it works for you?

@hehe123 @Mattches. Alas, still no luck. thanks for trying to help solve the problem though guys.

@Akorita,
I think that this issue is captured here and is being worked on presently:

Brave Browser Version: 1.1.20 Chromium: 79.0.3945.74 (Official Build) (64-bit)
OS: Microsoft Windows 10 Pro Version 10.0.18362 Build 18362

When i open hulu or netflix in Brave. I am prompted for the first time to allow WideVineCDM and i choose allow. I am not prompted to install the plug-in. There is no “puzzle piece” at the top of the browser. I feel like I have exhausted all the steps in this thread and still do not havea fix yet. I even tried opening a guest profile and was prompted a second time to allow the CDM, which I did. CDM is set to “Ask when site wants to install widevine on your computer” in my settings. If I open components it’s not on the list to “check for updates” implying that it is not installed.

Please send help.