I want to stop ALL autoplay

TEAM BRAVE, Please, get rid of video autoplay for all websites, it becomes unbearable,
Everywhere the brave blocking doesn’t work anymore, I’m sick of it.

4 Likes

Has anyone figured this out or is Brave doing something to fix this? I’m really tired of videos like the ones in the “LaptopMag” link below autoplaying when I have it set to Block in every way possible inside Brave. As a software engineer I’m baffled as to how this is not a simple fix.

As noted earlier in this thread and in other threads about AutoPlay, adding the AutoplayStopper extension

addresses and resolves the problem for me and for others.

1 Like

As I noted earlier, I think it would be a good idea to bake this into the browser. It’s a switch that does nothing at the moment. (if it’s still there in the settings)

No pushback from me, but I have no control over Brave’s development path. I do have control over the extensions I choose to install. (And yes, I understand that installing extensions entails some risks.) AutoplayStopper works for me and, reportedly, others.

1 Like

I realize there’s an extension. The reason I’m using Brave over Chrome or Edge is to block ads without needing extensions. If I have to start using extensions, I might as well just use one of the others.

2 Likes

I suppose I’m off to install an extension. Doesn’t this fall under the category of super fast and protected by default? Shouldn’t the extension be to allow autoplay?

I’m unsure how autoplay is a useful thing for anyone. Whenever I unlock my computer every site that has a video that autoplays starts. Every. So in the case I’ve been opening up tabs to watch later, that’s between 2 to 6 or 7 tabs that I have to find within 10s of tabs to hit pause.

I did find that particular sites can be set to autoplay off. It should be the opposite. Auto play should be off, unless I want it. I suspect its a way to prevent advertisements from being excluded. Which makes it worse, since Brave’s mission is to reduce the load of ads on your computer and connection.

my 2c. Please change this ‘feature’.

1 Like

I selected the “laptopmag” link provided in post #22 and no videos autoplayed. Anyone have another link that has autoplay videos I can test?

Anything on CNN. This sucks when you want to read a news article without having talking heads beginning to tell you what to think. Then again, I shouldn’t be going to MSM if I’m looking for news.

1 Like

Yes please, I would love a browser which doesn’t do this user-hostile stuff. Devs please fix.

I totally agree. What am I missing here? I joined Brave to have control. Where is the turn off autoplay button.

3 Likes

Welcome to Brave Community! I absolutely agree. We need to keep this topic alive. It’s embarrassing that we have to have a work-around for this still

I’ve tried Autoplaystopper with it blocking everything, but it stopped nothing. I’m reluctant to try Autoplay Blocker at this point. But this bandwidth wasting nonsense on websites needs to stop, and Brave needs to help.
Is there anything that currently works, and is safe, on this current version of Brave?

Installing AutoplayStopper stopped videos autoplaying for me and for others. YMMV.

For more than a year (installed 1 Sept 2019) I’ve been using AutoplayStopper. The extension does what it claims to do; others report similar satisfaction.

Mid-May 2020, a Brave moderator suggested Brave may have a fix in the works. Maybe. The Brave moderator then closed discussions of this issue in that thread.

The not-so-good news — resolving this (and other issues) with extensions has potential downsides: https://krebsonsecurity.com/2020/03/the-case-for-limiting-your-browser-extensions/

I am new here. this issue seems to be years old. is anyone at brave listening to anything in the forum??

The option is stll available, you can disable autoplay just here : brave://settings/content/autoplay.

1 Like

Thanks for the suggestion.

As others have noted in discussions about Autoplay, there’s apparently a “white list” (inaccessible to mere mortals) that permits Autoplay on some sites even when Brave’s Autoplay preference is toggled “Off”.

I have AutoplayStopper installed. I diabled it and, following your suggestion, toggled “Autoplay” to “Off” in Brave’s settings. I then visited a site known to me to have aggressive Autoplay behavior.

Sure enough, with AutoplayStopper disabled, even with “Autoplay” toggled to “off” in Brave’s settings, I was deluged with autoplaying content.

The solution for me: install AutoplayStopper. It works.

I’ve enjoyed my brief foray into Brave on mobile. However the video autoplay does need resolving on Android. There don’t appear to be addons to stop it and video play is particularly invasive and irrating on mobile. Tried changing the site setting but this doesn’t work for some sites.

If others have hints tips or similar experiences I’d love to know. Is there is a plan to address this?

Rolleroo

P. S. And on a couple of sites it freezes the page.

I agree. Videos don’t autoplay on Windows but they still autoplay on Android.

I have the same issue here. I selected ‘block’ for autoplay in the site settings yet videos are still autoplaying.