Is there ANY way to stop autoplay at Youtube?

Is there any way at to do it? ANY way? I see threads going back more than two years about people complaining about this.

The suggestions in those threads are useless as the paths to block autoplay no longer exist in Brave.

Can be done natively in youtube.com

  1. Go to the watch screen of any video.
  2. At the bottom of the video player, click the Autoplay switch to set it to On or Off .
1 Like

That was the very first thing I tried. That works with Firefox. It doesn’t work in Brave. It doesn’t work in Edge. It doesn’t work in Chrome. It doesn’t work in Epic.

It should work fine, when you play a video, it won’t autoplay the next. Just tested, working well here. Unless there is an extension installed causing issues?

Hello @phoebe_figalilly

you can also go to brave://settings/content/autoplay then either block it so it be blocked for all sites that play video/audio or just add youtube to the block list

hope that help :slight_smile:

1 Like

The YouTube Enhancer extension will do that too and much more :slight_smile:

I use all these YouTube related extensions.

This covers all my YouTube peeves not handled by ad blocking.

This one defaults the autoplay button to off.

This one pauses the video at start (except in a playlist).

Afraid not. There is no “content” icon in brave://settings. But thanks for trying.

copy the whole brave://settings/content/autoplay and paste it in the url bar then enter it will send you to the setting directly

This will only stop initial autoplay of embedded videos.

Once you start a YouTube video on their own site, it will still go to the “next” one when finished.

See above for add ons.

it will go to the next one if you enable the autoplay on the youtube interface but will get the next one but would not play it and that exact what firefox do as will
that why i replay with that check his comment below

I just did an experiment.

brave://settings/content/autoplay

… also interrupts playlists.

If you really want to tweak how it behaves, you might like this add on:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.