How do I disable autoplay of videos on Brave (desktop, Windows 10)?

I have very slow, internet with bandwidth caps (satellite). I’m wasting lots of bandwidth on videos that just start paying whenever I open a webpage. How can I stop this browser from autoplaying videos? I’ve found sets of instructions elsewhere but they describe steps that are impossible to follow on this current version.

**Steps to Reproduce: …
**Actual Result (gifs and screenshots are welcome!):…

**Expected result: Videos play ONLY when I select them and ask that they be played.

**Reproduces how often: constantly
**Operating System and Brave Version(See the About Brave page in the main menu):Windows 10; brave version :
Version 1.25.70 Chromium: 91.0.4472.77 (Official Build) (64-bit)

Additional Information:

You could try blocking Autoplay at brave://settings/content/autoplay.

3 Likes

At last, instructions I could actually follow.

Thanks for this thread. Yes, brave://settings/content/autoplay leads to Brave’s autoplay setting; for those interested, the full path (after clicking the hamburger icon) is: Settings | Additional settings | Privacy and security | Site and shield settings [expand] | Additional permissions [expand]

Autoplay is (on my screen) 3rd on the list (and yes, it’s set to “blocked”).

But, is this effective at stopping all autoplay? In the past, I found the answer was “not entirely”. A lot of stuff leaked through. To combat this I installed AutoplayStopper.

I figured — with the guidance from @Rethanis — perhaps Brave had upped its internal autoplay blocking game. With the Brave Autoplay setting set to “blocked”, I disabled AutoplayStopper, closed and restarted Brave, and checked a few web pages with known autoplay activity. Brave reduces it, but doesn’t eliminate it. I toggled AutoplayStopper “on” again, and for me, all is well.