Disable YouTube Autoplay on Page Load?

Description of the issue:

I have autoplay turned off in settings, and have even gone as far as specifically adding youtube.com to the block list. However, whenever I open a YouTube link, the video plays immediately on page load, which is not what I want.

How can this issue be reproduced?

  1. Turn off autoplay in Site Settings.
  2. Navigate to any Youtube video.
  3. Video will play (grumble)

Expected result: Video does not play until I click on the play button

Brave Version( check About Brave):
Version 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

Additional Information:
Mac OS mojave 10.14.6

@qxq8d4on,
Thanks for reaching out to us.
Can you try clearing cache/site data and resetting permissions on Youtube to see if this helps resolve the issue at all?

  1. Visit Youtube.com
  2. Click the “lock” icon, then Site settings
  3. Click both Clear data and Reset permissions
  4. Scroll down the list of permissions and find Autoplay, set this to Block
    • There’s a chance you may encounter a small bug here where you click Block in the dropdown, but Allow is still displayed. Ensure that you have clicked Block even if Allow is displayed afterwards.
  5. Make sure you refresh the page when prompted.

Let me know if this works for you – when testing this issue, I myself realized that Autoplay wasn’t getting blocked (will have to dig into this further) and these are the exact steps I took to get it to work.

OK, I’m getting the same thing as the OP in same version of Brave and macOS. I tried your suggestion, and the setting will not change from Allow. When I select Block or Block (Default), it just goes back to Allow.

Also, before I tried that, I tried going to the setting directly, and when I turn the toggle to “Blocked” in the detail setting, the list of site settings still says “Ask,” but it doesn’t even ask with either toggle.

So I tried adding youtube.com to the block list and did a Shift-Cmd-R to force reload, and that worked:

HOWEVER, it doesn’t appear to work in Nightly (0.71.68 Chromium: 76.0.3809.132 (Official Build) nightly (64-bit)). When I get more time, I’ll tinker more.

1 Like

Thank you! This did indeed work.

I also did get the bug you mentioned about it saying Allow still, if that helps you diagnose that. But it seems to successfully be blocked.

Thank you for the help and the quick response!

Just came here to note that this is actually a known issue that we’re addressing. Issue can be tracked here:

I added a few notes of my own from when I’d encountered this problem previously. Also, @hnktong, your report/testing was so useful I went ahead and quoted you directly in the issue to help solidify the case for the issue – I hope you don’t mind!

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.