Block auto play works, only when extensions are disabled


After a bit of messing around with why blocking auto play of videos is not working, i managed to find a work around and stop videos from auto playing.

Only by disabling my extensions, ublock origin and no script, i could get brave to work as intended and it would stop auto play of videos.

1.Disable my extensions
2.Open youtube, select a video,
This even works when i have someone’s channel open and i open one of their videos in a new tab,.

Expected result:
Enable my extensions and youtube videos will revert to playing and ignore the “enable block auto play”

Version 1.24.86 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Why would then, extensions be effecting braves settings this way

Here’s with my extensions on and you can see the logo in the address bar showing “auto play video blocked” enabled.

This is with my extensions disabled and notice that youtubes own “auto play” is turned on, and brave still stops the video from auto playing

I checked this, Extensions shouldn’t affect this, unless its a specific extension (youtube/video/auto-playback etc). Which extensions do you have?

Only Ublock origin and no script.

Both are up to date

With extensions enabled, If i go to a user’s channel ,then open one of their videos in a new tab , it would always ignore the auto block and play the video, but once again, disabling my extensions fixes the problem.???

I just tried with disabling ublock origin, and only having no script enabled and everything works. As soon as i enable ublock it breaks auto play again???

I have youtube.com and googlevideo,com set to temporary trusted in no script.

No script and uBO can cause issues, No script can (and will) break javascript. uBO has “on click” filters also, which will affect youtube playback.

I would disable uBO, then test youtube. The renable uBO and disable Noscript. Re-test youtube. See which extension is causing the potentional issue

I’ve been running with only no script for a few days now, and everything is working as it should. So it seems it’s something to do with ublock,???

Unsure to be honest. But good to see its fixed