High GPU load on YT and Twitch

Today I switched from Chrome to Brave, but when watching YouTube or Twitch 1080p or higher on a 4K screen, my GPU temps go above 70C and fans are loud. I don’t have this problem with Chrome (same stream/video), GPU is below 40C and fans are quiet. Is there some setting I can change to fix this or do I have to look for a different browser? Thanks.

Brave version 1.60.118, desktop, Windows

Yes, but the question is which one? And no, it’s not within Brave. It would be your device and graphics card settings. There are plenty of topics on issues surrounding YouTUbe, Twitch, graphics cards, etc. We even have plenty of topics here on Community, if you’d Search Before Posting. As stated earlier though, there’s no one magic answer and it can be tricky to know which setting(s) would be causing problem for you.

If you have issues, especially with Hardware Acceleration enabled, then it means either your graphics card is trash or your settings are restricting behavior. Challenge is going through your settings to see how they differ and also making sure all drivers are updated.

Each of these are different symptoms and may not read exactly as you’re mentioning, but it’s kind of critical to look.

Some examples of posts can be seen below:

Disabling hardware acceleration in Brave settings seems to have fixed it, the temps are 45-50°C now, thank you

forgot to say I have RTX 3070 and for some reason 1080p Twitch stream made my GPU hotter than 4K youtube videos

Not really a fix but is an indication of what I mentioned earlier. Graphics card settings on your device needs adjusted.

Hardware Acceleration on means it uses your graphics card (GPU) to run tasks and video. Usually it’s more efficient and higher quality.

Hardware Acceleration off means it uses your CPU to handle tasks and videos. This usually places more burden on your device and is lower quality.

If ever see more burden when Hardware Acceleration is on then either you have a faulty graphics card/driver or your settings aren’t playing nice and is creating extra burden.

To clarify, what you are saying, and that turning off hardware acceleration fixes the issue is that your graphics card load is decreasing because you’re turning it off. We’re at least you are rerouting some of the usage away from your graphics card into your CPU instead.

You should go into your Nvidia settings and check out things like what you have for anti-aliasing, 3-D settings, etc. Also, make sure you don’t have anything like maximum background framerate or whatever. Try to compare what you have for Brave compared to chrome and everything else. Or you can even just try to reset your graphics driver and see if that makes any difference.

It’s just difficult to have any one solid answer because the problem and solution for each person has been a little bit different. The only thing that is common is that it has been something within their settings or driver itself.

Disabling HW Acceleration will offload the GPU load to the CPU, so might be a little more choppy. Would test in private window mode to ensure no extensions is causing issues. Also update GPU drivers

If you aren’t gaming, Make sure to change your power management mode to optimal power this will reduce your temps and watts consumption of PC ultimately

1 Like

Resetting Nvidia 3D settings for Brave to default didn’t work and I update my drivers fairly often. But this time when Geforce Experience found an update, instead of pressing Express Install as usual I chose Custom > Clean Install, and this seemingly fixed my problem. Thank you for your time!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.