Hardware acceleration broken - YouTube videos flickering, anti-aliasing broken

NOTE: I’ve been actively using Brave Browser until a few months ago with no issues, but after some update, it suddenly broke and started showing issues described below. So I’ve immediately switched to Google Chrome.
Today I’ve revisited Brave to check whether the problem is solved, but unfortunately it is not - that’s why I’ve decided to report this issue.

Description of the issue:

  • YouTube videos flicker when hardware acceleration is enabled.

  • Everything looks a little bit ugly (not anti-aliased and blurry) when hardware acceleration is enabled.

  • When I visit brave://gpu, my GPU starts to coil whine. But it stops immediately when I switch to another tab.

How can this issue be reproduced? N/A

Expected result: Videos shouldn’t flicker and fonts should be smooth when hardware acceleration is enabled. Disabling hardware acceleration is not a solution as it significantly reduces performance.

Brave Version: 1.33.106 (clean install, no extensions)

Additional Information:
OS: Windows 10 Pro 21H1
CPU: AMD Ryzen 5 2600
GPU: NVIDIA GeForce RTX 2070
GPU Driver Version: 497.29 (latest)
Display Resolution: 3440x1440

Also brave://gpu does not report any issues in Log Messages.

Thank you.

While you wait . . .

You might try:

Disable hardware acceleration

brave://settings/system?search=hardware+acceleration

Quit everything and restart your Windows OS based computer.

Start Brave Browser and observe performance at website(s) of interest - related to the problem your computer has.

Next, enable hardware acceleration . . . and see what happens.

Later, you might find some hints/tips in the following links:

Again, something to take a swing at, while you wait, if you wish.

1 Like

@weyland,
Are you doing something in-browser that explicitly requires/benefits from having HWA enabled? If not, I would highly recommend disabling it. I know you said it’s “not a solution” but I can almost guarantee you that all three of the issues you’re describing above will be resolved by toggling the feature off.

Brave and HWA often have a hard time getting along – we have some documentation on why this is and some steps we’ve taken to resolve it:

However, for now, this is the reality of the situation. Can you please test and confirm that disabling HWA does in fact resolve the issues you’re seeing?

1 Like

While I haven’t noticed any flicker in my youtube videos, I can confirm that disabling HW does fix the blurry issue.
The problem is that without HW, the CPU use just by watching a youtube video becomes unbearably high, reaching around 50% in my i3-8100.

1 Like

Just want to join this thread, and report that HWAccel is also broken on my PC when using Brave.

This problem only started from few days ago. When HWAccel is enabled, not just Youtube, but the videos in Facebook also flicking.

Turn off HWAccel works, but then Whatsapp web become sluggish. So, far from ideal.

The Brave version now is 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit).

Windows 11 version 21H2 build 22000.376.

1 Like

Well, I’m a web developer and among other power-hungry things, I work with in-browser 3D libraries / WebGL, so hardware acceleration is essential for me. And not only that - there’s, for example, also a very low performance when playing 4K videos with HW acceleration disabled.

However, I can confirm that disabling hardware acceleration does resolve those three issues.

I’d also like to note that I have no issues with hardware acceleration in Google Chrome.

Good news, I’ve fixed it!

Today I’ve downloaded Vivaldi browser just to test it out, and noticed that it had the same exact issues - this meant that the cause wasn’t probably in the browser itself. So I got an idea to reset “Global settings” to default in NVIDIA Control Panel, and IT WORKED!

SOLUTION: Reset “Global settings” to default in NVIDIA Control Panel.

This means that it was caused by some setting in NVIDIA Control Panel, but I can’t tell which one.

2 Likes

Resetting all Nvidia control panel settings did work for me but I use those other settings so I narrowed it down to the Max Frame Rate setting. Using the individual Program Settings to turn off Max Frame Rate just for Brave also fixed the problem and allowed keeping the other settings.

2 Likes