Error on yesterday's update [Windows "blank window" issue]

Several people on the github post have tried it and said it didn’t work for them. I tried it and got the following message: “The name ‘c:\Users…exe–disable-gpu’ specified in the Target box is not valid.” I put in quotes in a second try and got the same message.

1 Like

@Lauren,
You need a space between the quotes and the flag itself. Try again and ensure you include a space:
"~This / is / a / path" --disable-gpu

1 Like

And there it is. It worked. I used the bravebrowserstandalonesetup file that I kept. However, it didn’t work for the icon that the program put on the toolbar at the bottom. When I use that link it still shows the blank screen, so it needs to be done individually for each icon.

1 Like

@Lauren, progress!
Many users have reported that the flag doesn’t work but i’m glad to hear that it worked for you!
You are correct about the shortcut on your toolbar – This flag is a workaround, rather than a solution. The path you’re modifying applies only to the shortcut you’re editing. It’s not changing the actual launch behavior of Brave itself.

We still have a lot to work out as far as this issue is concerned but hopefully this flag can help users at least get started.

That said, @Lauren, I’d like to see if we can make this a permanent solution as well. You need to disable Hardware Acceleration in Brave’s settings so that any time Brave is launched using any shortcut, it will load with that setting already configured. Try the following:

  1. Launch Brave using your --disable-gpu modified shortcut
  2. In Brave, open the main menu and navigate to Settings --> Advanced --> System --> Hardware Acceleration
  3. Toggle this option off and close Brave
  4. Relaunch Brave using any shortcut that is not modified

If all goes well, the browser should now launch and display correctly every time. Let me know the results.

2 Likes

It worked. I used the link in the bottom tray, then took the additional text off the other. Both links are working now.

3 Likes

Apologies to any Win7 users here who were getting blocked by this. We truly appreciate your patience and assistance with addressing the issue. There’s clearly something going on under the hood with respect to Brave and Win7 display settings. We’ll work that out on our end, but this workaround should suffice for now.

For anyone in this thread (or just now getting here), I’m marking this as the “solution” temporarily. There’s a chance this may not work in all cases. If you attempt this solution (see below) and it does not resolve the issue, please leave a reply in this thread and let us know so we can further troubleshoot.

Workaround for Windows 7 Blank screen:

  1. Find the shortcut for Brave (generally on Desktop), right-click and select Properties from the context menu.
  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes. It should look something like this:
  3. Click Apply then OK then open the modified shortcut you just created.
  4. Assuming this worked and you’re able to view Brave, open the main menu on the top-right
  5. Navigate to Settings --> Advanced --> System --> Hardware Acceleration
  6. Ensure this option is off. If not, toggle it off and relaunch:
  7. Now, return to the modified shortcut, remove the --disable-gpu flag from the Target path and launch Brave using that shortcut.

If everything was successful, you should now be able to launch and use Brave as intended. Again, if this didn’t work for you let me know. A special shoutout to @Lauren for jumping through about 5000 hoops and helping me diagnose this :slight_smile:
EDIT: Also shoutout to @clippy for inspiring me to try the flag again (as it had previously failed).

7 Likes
Windows 7 latest brave update
Installation issue: White Screen when it first started
The Brave browser does not start is put on the black screen
Brave will not download
Downloaded Installer, Installed, only get blank screen when Brave opens
When i open a brave browser, it shows white screen, ihave A315-41G my ram is 4GB
I can't open the brave exe app in windows 7
Opening brave doesn't have the window launch or a process in task manager
Can't open Brave
Brave keeps freezing my PC very often
Brave crashes on launch
Some data points you might be interested in regarding failed install of Brave on Win 7
Brave browser opens up blank after windows update
Brave browser opens up blank after windows update
Links working but Black Screen on starting
Problems installing on a Win 7 Notebook
Brave does not Load at all after Installation
Full Black Screen after GPU Update
Continue where you left of - deleted
Browser is Not working in Win & 32 Bit
White blank page on Windows 7 64 bits
Brave is showing black square (no icons, links, etc) this morning
New Brave - windows 8
Windows 10 - Black screen on opening Brave, all windows, just completely black
Brave Crashes as soon as opened
I think worst browser
Installation of brave newest version
Brave Crashes as soon as opened
Added duckduckgo as search and then black screen
My brave is not responding, beta and brave official how to fix?
Brave does not start after being reinstalled
Brave Browser didn't open on windows
Brave black or white page only
Current Brave download gives Black Screen upon new Win10 HP DV6 Laptop Brave install
Unable to install on windows 7 ultimate x64
Brave Browser only shows empty white windows
Brave empty windows at launch. no icone, nothing
Empty window + unable to uninstall
Brave Crash/White Screen
Clean install - Brave crashes within seconds of launching
Update on Brave being flagged as malware (false positive) by Kaspersky Anti-Virus
I installed Brave on my laptop it is not supported by my graphic driver and just showing black screen
Brave dont work on mini pc , test it on 4 different mini pc
Brave crashes every time it launches
Black screen !? not available for use
Blank winodw after installing
Black screen error

Terrific! This worked for my husband’s computer (Windows 10). Thanks so much for figuring all this out.

1 Like

My pleasure!
Appreciate your patience through all this.

Yes ork like a charm. Yeahhhhhhhh

1 Like

I thing it’s comming from chromium itself, Today i installed Chromium and Same Problem Occurred and Same ( --disable-gpu) fix work for that…

, Hope you patch soon, wasted a lot of time on this

Did launching with this flag not resolve the issue?

Yes it Resolve the issue…:+1::+1::+1:

1 Like

Did it like explained, and it’s now working propperly!
Many thaks!

2 Likes

I’ve just installed the lattest version for Windows 64 bit and experienced exactly the same issue. I tried this solution and it worked. Great and many thanks @Mattches.

2 Likes

Hey Mattches,
i’m using Win 10 64. was able to insert the --disable-gpu, Bada Bing/Bada Boom. back in biz. (at first i thought it didn’t work but went back and checked everything and saw i was missing the little dash before ‘gpu’). was able to turn off hardware accel too. hope this fixes it and great thanks. so nice to have my Brave back.
peace out,
shivad

1 Like

Perfect!
Working in Windows 8 also.
Thanks a lot!

1 Like

hi there i did follow all those instruction but its stayed black on screen … i am using windows ultimate

@poseidon2125,
Can you show me what the modified Shortcut target looks like on your end?

Hi,
Thanks a lot… Its working in win 7. Thanks again and again. I appreciate your quick response.

Best Regards
Shiji A V

1 Like