Brave Freezes on Launch

#1

I have attempted installing the Brave browser, uninstalled it, installed different versions of the browser, and all of them do the same thing on launch: freeze. I’m eager to try this new browser, and I can’t get the app to do anything except stop after it opens. I’m running a Windows 10 Pro machine (version 1809) and the app isn’t active long enough to get data from it. Please advise.

#2

@mtwoodward,
Thanks for reaching out. This sounds like a similar issue to what Win7 users were experiencing:

Taken from that thread:

Apologies to any Win7 users here who were getting blocked by this. We truly appreciate your patience and assistance with addressing the issue. There’s clearly something going on under the hood with respect to Brave and Win7 display settings. We’ll work that out on our end, but this workaround should suffice for now.

For anyone in this thread (or just now getting here), I’m marking this as the “solution” temporarily . There’s a chance this may not work in all cases. If you attempt this solution (see below) and it does not resolve the issue , please leave a reply in this thread and let us know so we can further troubleshoot.

Workaround for Windows 7 Blank screen:

  1. Find the shortcut for Brave (generally on Desktop), right-click and select Properties from the context menu.
  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes . It should look something like this:

  1. Click Apply then OK then open the modified shortcut you just created.
  2. Assuming this worked and you’re able to view Brave, open the main menu on the top-right
  3. Navigate to Settings --> Advanced --> System --> Hardware Acceleration
  4. Ensure this option is off. If not, toggle it off and relaunch:

  1. Now, return to the modified shortcut, remove the --disable-gpu flag from the Target path and launch Brave using that shortcut.

If everything was successful, you should now be able to launch and use Brave as intended. Again, if this didn’t work for you let me know. A special shoutout to @Lauren for jumping through about 5000 hoops and helping me diagnose this :slight_smile:

:point_up: Can you try the --disable-gpu solution on your end to see if it resolves your issue?

#3

Sorry for the delayed reply. I tried those steps and Windows would not let me make those changes, even with the Administrator access I have. I was able to disable the NVIDIA GTX960M driver in Device Manager, and Brave would run. Once Brave was launched, I enabled the video driver to see if it would change things, and Brave launches fine, even after multiple restarts. That video driver is affecting other apps too. Thank you for the guidance.

1 Like
#4

@mtwoodward,
My pleasure – and great detective work on your end! Glad you got this resolved. Please don’t hesitate to reach out with any questions or concerns.

closed #5

This topic was automatically closed after 30 days. New replies are no longer allowed.