Brave Shields panel individual javascript source selection - Allow function - lost with Browser v1.38.109 update

Description of the issue:

Prior to Brave Browser v1.38.109 (released Apr. 27, 2022), Brave Shields panel (Lion icon, right end of URL address field) had a function that provided for you to individually select the sources for javascripts that you choose to Allow.

Now, that freedom to Allow certain javascript sources - but still block other script sources - has been removed.

How can this issue be reproduced?

The freedom to choose: individual script source selection and then choose to Allow (function) - has been lost because of the Brave Browser v1.38.109 release/update.

Expected result:

That the traditional Allow function - for individual sources of javascripts - should remain.

Brave Version( check About Brave):

Brave Browser v1.38.109 (for desktops, released Apr. 27, 2022)

Additional Information:

Related issue at GitHub:

https://github.com/brave/brave-browser/issues/18630

See for some recent comments, here at Brave Community:

https://community.brave.com/t/updated-design-for-brave-shields/383855

New, not-workable design (Brave Browser v1.38.109):

Traditional, good-working design (Brave Browser v1.37.116 and earlier):

Illustration (borrowed from Brave Help Center):

A javascript icon that I miss:

1 Like

@Mattches , @Johann , @maddad , @JGHall ,

I restored Brave Browser v1.37.116 to my Mac computer, in order to get the (ebay.com) screenshot above (Original Post), and continue to use the older, worthy version of the Brave Shields panel functions.

The ability, using the Shields panel, to make the selection in order to Allow the source for the javascript that you approve - while still Blocking other javascript sources - for a given website, was a major reason for using Brave Browser.

They say it’s intentional, but why though??

Thanks! You can add exceptions each time you visited a new website, but at least it would only be on the first visit as the filter would remember your choice for subsequent visits.

A hybrid would be good - being able to individual select whether to allow / block, and additionally whether that allowed script should be added to the exceptions list.

1 Like

I liked the change settings one time feature better. Now when using the shield the script changes are permanent for the site. You have to manually remove the changes before exiting the site. That was one of my favorite features of the shields, you could set and forget because when you closed brave, everything reverted back to your preferred settings.

1 Like

@IanMoone ,

I am still digging around, trying to find out, the “why?”

I have installed NoScript as a temp measure. I really hope the developers will fix this or at least respond with whats going on. If we have to add extensions then we aren’t much better off than firefox.

Please note that I have brought this information up to the team for review. In the interim, I would advise not downgrading your browser for this feature. Instead, we have implemented a flag you can enable to revert Shields itself back to Shields v1.

Simply go to brave://flags and search for brave-shields-v1, set this flag to Enabled and relaunch the browser when prompted.

Thank you.

4 Likes

Thanks - enabling shields v1 and disabling shields v2 works nicely

1 Like

Thanks Mattches and JGHall. I didn’t know about the experiment options. That trick is great and I don’t need an extension after all. Big thanks to the support techs here, its very much appreciated. I hope the issue will be resolved permanently soon.

Any feedback on this so far?
This change is on a level like Windows ME for me.
Well thought poorly done.
No idea who approved this change…

Came here looking for this specific issue. Thank you for making the post. I would like the v1 toggles back as well.

The Brave flags solution works. Make sure you enable v1 and disable v2 or you’ll have two Shields icons in your bar.

1 Like

You avoided explaining yourself about the downgrade in both functionality and design.

Will there any update from the team at all?
I mean you said you bring it to the team. Silence is not the best answer in this case.