Enable Javascript icon in url missing

This question is in addition to what is listed here: Enable Javascript icon now missing
The above describes how the url icon to enable Javascript is missing in newest Brave version with Github links showing that removing that feature was a development goal that is now complete. I’m re-asking in a sense because @Mattches could not reproduce (see below) and it is closed so I can’t add there.

Description of the issue:
So the url icon to enable site specific JS was removed - fine. But what is the solution now to site-specifically enable JS for one time use?

I have JS globally disabled in Settings and use the advanced Shields view.

Old behaviour:
If a site had JS and I cared to enable it, I would use the url icon to enable it for that site, that visit (one time). Great.

New behaviour:
No icon so… In the above solution, it is advised to use the scripts section of the Shields badge. However, those scripts do not include Javascript scripts (JS is not seen in any of the lists in the badge, and enabling all scripts by that method still leaves JS blocked). The ONLY way to run JS now is to turn off ALL shields and so accepting all trackers etc and basically turning off all the functionality that I use Brave for. Or I am missing something

I do know that I could go into the Settings and add the particular site as an exception to the JS blocking, but I only want to do enable JS once, not globally.

How can this issue be reproduced?
I am reasking because the moderator (@Mattches) was confused and could not reproduce because for them the icon was still there (Enable Javascript icon now missing - #9 by Mattches). They advised “you could and should be using Shields for this” but that is not accurate (at least if you are using a version where the url icon no longer appears)

I use mostly Mac but just updated Brave on my Linux system and lost the url icon there too. I will try to roll back

Love Brave btw but really appreciated this feature that is now gone.

Expected result:
To be able to enable JS for a site on a one time basis without adding it globally to settings and them removing later if you only intend to enable for a single use.

Brave Version( check About Brave):
Version 1.20.103 Chromium: 88.0.4324.152
Same behaviour on both Mac and Linux systems

Additional Information:

@333,
Perhaps I’m confused – you should see Javascript being blocked in Shields as well. Can you tell me the specific site(s) in which JS is not being blocked when Block scripts is enabled? I’m also unclear on

However, those scripts do not include Javascript scripts (JS is not seen in any of the lists in the badge, and enabling all scripts by that method still leaves JS blocked).

You don’t see JS blocked but enabling all scripts via Shields means that JS stays blocked? Can you elaborate or rephrase please?

Additionally, if you open your Shields panel, there is an option to Allow scripts once in the Shields panel as well:

Using Javascript blocking in Settings and the advanced Badge view.

For example, twitter.com in this circumstance yields a screenpage notification that Javascript is required.

Old behaviour:
I would have clicked the url icon to enable Javascript for this one time visit.

New behaviour:
From Shields Badge: “Enable all scripts” yields the same screen (so Javascript scripts are not among the scripts being blocked/enabled with that feature, just like previously where you would need to enable Javascript with the url icon, separately).


All Shields down: then you can view the page with Javascript enabled (but all shields are down, negating the purpose of using Brave for trackers etc).

So yes, enabling all scripts leaves Javascript still blocked (because I have it globally blocked in Settings, as I had previously. So javascript scripts are not among the scripts affected by that feature in the badge).
Javascript is enabled only by lowering all shields in this scenario (no longer have the option to use the url icon to do so for one time use, as I had previously).

Does that clarify? Same thing for community.brave.com or any other site requiring Javascript to view properly.

Ooooookay I get it now - and I’m posting here to complete the thought - for other people like me.

Above I showed that enabling all scripts does not enable Javascript. However, if you use the slider, you CAN stop Javascript blocking WITHOUT lowering all shields.

I guess you just lose the resolution to be able to selectively block scripts while using Javascript – like in previous versions, which I appreciated and used frequently.