HELP! JavaScript is blocked on all sites

windows
#1

So I’ve been using Brave for about 2-3 days now. At first it was all good then suddenly Brave started blocking JavaScript on every site I visit, even the sites I visited previously. I don’t know why this happened, I haven’t even touched any of the advanced settings before.

I tried disabling it but where there was supposed to be a disable/enable option, there was nothing. Just a white and black list.

I use a Windows 10 64-bit laptop, btw.

If anybody can help me, I’d really appreciate it. :smile:

#2

@mearows,

Are you referring to the Shields panel (shown below)?


If so, can you share an image of what you see on your end?
If not, can you elaborate a bit on what you mean?

#3

On my end this is what the Shields panel look like:

And I’m not sure whether or not this is the cause for my problem. (Shown below)

This keeps happening whenever I visit a new site and I’d pretty much like for my JavaScript to be automatically on.

#4

@mearows,
That’s interesting – can you show/tell me what your default Shields settings are set to?

#5

Sure! Here you go.

#6

@mearows, thanks for the info!
I would highly recommend you read the three Shields articles on the Help center to better understand how Shields function while browsing (I say this to everyone, don’t mean to offend :slight_smile: ). If you toggle the bottom option off, all sites that have not been adjusted in the shields panel will default to Scripts blocked when visited.

That said, I assume you haven’t altered those settings since the first install of the browser, did you? I ask because Default Shields should start with Scripts allowed - as shown in the image below: