Enable Javascript icon now missing


Description of the issue: I have the Disable Scripts turned on in my Brave settings. Typically when would go to a website that blocked javascript, there would be a small icon in the right of the address bar that I could click on to manually enable Javascript for a website. That icon is no longer present.
How can this issue be reproduced?

  1. Open Brave.
  2. Go to website with Javascript utilized.
  3. Enable Javascript icon fails to appear.

Expected result: Enable Javascript icon would appear and allow me to manually enable Javascript for a website.

Brave Version( check About Brave): Version 1.19.86 Chromium: 88.0.4324.96

Additional Information: I have tried un-installing and re-installing the browser completely, but the icon still does not show up.

@doubletrout,
Instead of using that icon (I’m digging into whether or not we know about this issue, more on that when I get more info), you can open the Shields panel (lion icon in the address bar) and enable JS via the Shields toggle. Note that settings configured in the Shields panel are site-specific, so if you have JS disabled by default (Settings --> Shields) you can change the setting for specific sites without affecting default behavior.

Also seeing the same problem.
Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (x86_64)

Was there just a few hours ago. Definitely a bug if it’s from the exact same version.

Can’t look at sites easily anymore without having to put shields down instead of just enabling javascript only.

Same problem - the Javascript icon no longer appears.

Same version:

BB Version 1.19.86 - Chromium Version 88.0.4324.96

With the icon, we do not have to guess.

Let us use this Brave Browser webpage, re this issue:

When the icon is present, I know that I need to copy:

https://community.brave.com

and enter that as

https://community.brave.com

to be enabled, at:

Settings > Additional settings > Privacy and security > Site and Shield Settings > JavaScript

I have been doing that, for a long time, now.

It works; and I do not have to guess about the JavaScript status.

But now, with the icon missing, I have to wonder, Do I need to enable JavaScript for this website? Wander up and down a webpage - and guess, maybe / maybe not. Cannot tell, at a glance.

Spend more time wondering, than getting to the Settings > . . .

Discovered another but - on this webpage re this issue.

In my reply to you, I wrote, “and enter that as” (no spaces)

https://community.brave.com : 443

That is “https://community.brave.com” followed by a colon followed by 443 - in that example, I placed spaces on both sides of the colon, attempting to convey.

But only “https://community.brave.com” shows in my original reply to you.

There is no feature of this process - replying - that allows us to review how our reply will appear.

is this “issue” related to this change here?

The icon should still show up, regardless whether the place to change it is different or not. But not being able to add it permanently is also an oversight. I don’t see that in the shields panel.

The old method was better tbh. Maybe make the scripts switch button in the Shields dialog box into a slider-bar instead with the options starting from left to right

allow all scripts for the site
allow javascript only for the site (adds to allow list)
allow no scripts (block all + remove from allow list)

with the option to allow scripts just once as it currently has as well.

well it seems here is the answer, only now we’re seeing it guess;

seems like a step backwards.

perhaps the brave icon should have had the “some kind of badge” implemented specifically for scripts before the JS script icon was removed.

now it’s just a guessing game. :roll_eyes:

I’m very confused. As I was saying before, you could and should be using Shields for this.
For example, if Javascript is disabled for sites by default, you should see the following behavior:

  1. Visit a website – in my example I’ve used ign.com but feel free to use any site that may be running scripts.
    • Also, now that I’m performing this test, I’d like to note that on my end I still see this icon so I’m not exactly sure what the deal is. I’ll be running this by the team:
  2. Javascript is disabled by default which means that any scripts running will be caught and blocked by Shields along with a count of how many items/elements were blocked:

:point_up_2: While I realize it’s not quite “at a glance”, it’s a very easy way to check and see if any JS items were blocked (and further, you can click the down arrow and see which scripts were blocks and even allow specific ones to get through).

1 Like

Yes Doubletrout. I am listening, but on my settings, Javascript is blocked by default, and I cannot unblock it. I now have to take each address and add it to the allowed list, a bit cumbersome. When I also try to enable it from the Shields interface, the button is off and won’t budge to the right, like it is blocked.
Is there a way I have not figured out to unlock it in the settings?
Thank you.

@DenysPicard,
No you do not have to “unlock” anything in settings. You should be able to go to Settings --> Shields and use these options to configure the default behavior of Shields on websites. Further, when on a website, you should be able to open your Shields panel and configure them for that specific website. There is no locking mechanism that we put in place.

Can you tell me if you have any extensions installed and can you also share a screenshot of what your default shields Settings --> Shields are set to?

Thank you. Ya…you know I am so adroit with these that I did not test on other sites when I tried, I tested on sites where I had already allowed JS. So, naturally, after leaving my comments here earlier, I said to myself 'hey s…"…why don’t you try a website you have not been on. And effectively, the little knob script on the shield pushed to the right, became red (I have to put an edit here, I think I am a bit tired, in fact I pushed the little button that was red to the left, it became grey and the stuff appeared on the page…Ha Technology!), and the visual animated on the page. Thank you, and don’t you go setting any fires on my account now!

1 Like