Brave search engine stuck on microsoft bing

Everytime I try to search using brave, it always uses microsoft bing even though I deleted it as a brower.

Hi @Oceanshu, let me know if you’re unable to switch your default Search to Brave. Thanks!

I am at the moment, got any fixes?

What happens when you follow the instructions in the above link, it’s not changing the default?

1 Like

It just doesn’t work, I tried changing to Google and it always uses Microsoft Bing to search.

What Brave version and OS are you using?

Brave 1.42.88 on IMac?

Thanks @Oceanshu can you share a screenshot of this page - brave://settings/search.

Can you search for something in Bing and paste us the URL you get in the address bar after your search?

Also, can you add a screenshot from brave://extensions/ ?

OK. How exactly are you conducting the search attempt? Can you tell us the specific steps you are taking?

I tried to search something on brave and it always redirects me to Bing

Yes, but what I mean is how are you actually doing the search? For example:


  • Type something in the URL bar (“address bar”) and press Enter
  • Redirects to Bing


Looking for the specific steps that are leading to this result.

It’s the second one, I try searching something in the address bar then redirects to bing

OK. Can you add a screenshot showing what the URL bar looks like when you type your search terms, but before you press Enter?

I notice it doesn’t show ‘Bing Search’ text after what you typed, for example:


After you typed the text, did you click out of the URL bar? That would make the ‘Bing Search’ text disappear. But I am wondering if you did that, or if it never appeared in the first place.

And just to make sure I understand, if you simply press Enter after doing this, you end up on the Bing search results page?

Have you tried it with that RoPro extension disabled?

Also, it looks like you have multiple profiles. What extensions do you have in the other profiles?

Hello! So basically when I click enter it just redirects me to bing even though it was google. I am pretty sure I never clicked out and the “bing search” never appeared. The second profile is for testing which have no extensions. Also disabling RoPro doesn’t work.