Can't Set Brave Search As Default Search on Desktop

I have Brave as my default browser on my desktop, but it will not allow me to set Brave Search as my default search engine. I am running Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

I have gone through all the guides and setting Brave Search as my default search is literally not an option.

I have images if that helps.

Could you paste the images here? Might help us solve the problem.

These are the screenshot I was referring to. The option to make Brave the default search engine is not available in either screen.


I’m curious why you opted to choose Bing for the demonstration. Anyway, let’s troubleshoot this.

I’ve seen that you are on the submenu “Manage search engines”. Have you tried changing the option “The search engine used in the address bar”? There’s a submenu next to it, see if you can find “Brave” in it.

No? Okay, follow the next steps: >>

  1. Go to brave://settings/searchEngines. This should take you directly to the “Manage search engines” menu I mentioned before.

  2. In “Other search engines”, click “Add”. Should give you with a pop-up. You should see something similar like this screen:

    image

(Don’t mind the foreign language. [Not really english here.] What matters is that your pop-up menu is similar to this.

  1. On the first text field, type any name you want. What is important is that it might be recognizable. Put Brave if you want it like the original, that’s fine.

On the second text field, put :br. (Note that Brave Browser might give an error. In this case, type anything else.)

On the third text field (IMPORTANT!!!) input https://search.brave.com/search?q=%s&source=desktop. ("%s" is for the search query.)

See if it works!

Thanks for your help :slight_smile:

In answer to your first question re Bing, I don’t use Bing, that is where the sub menu appeared.

The other thing I discovered when trying out your instructions is that there was a section that said “DuckDuckGo manages this setting” (or something similar). When I disable DuckDuckGo, I was able to choose Brave as the default.

Thanks again for your help!

1 Like