Brave is very slow

  1. Have tried toggling Hardware acceleration, makes no difference.

  2. I’ll try this in a few minutes when Brave has restarted… Everything on Flags is set to Default except “Use Chrome Sandbox” which is disabled. I will set “Enable Brave Sync” to Disabled now. Does this need to be done on multiple profiles?

Update: tried it, restarted, Brave is now spinning its wheel as usual. It does (as usual) start loading pages and gets some way through some of them, then the app just locks up, gives me the spinning wheel until 4 or 5 minutes later. I’m typing in Safari in case you were wondering.

  1. I have multiple profiles which I use for different jobs. I get freezes no matter which one is re-opened on shut down. If the answer is to completely delete all profiles and user data (which would be a tremendous pain in the arse) can you point to a

Buffering means your connection is to slow and maybe you open too many Tab browser that’s why your browser got slowed, make sure your internet is stable and you have not a problems on it because sometimes that’s the reason of many user’s. Correct me if I’m wrong thank you and have a nice day. :slight_smile:

This happens when opening brave with zero browser tabs open. It has nothing to do with network.

Currently on v84.1.11.97

  1. Have now disabled Hardware Acceleration. Still need to restart browser to apply this change.
  2. Had many issues with Sync v1 crashing Brave browser over and over, ultimately disabled it (quite some time ago) prior to the sluggish / performance related issues creeping up. All brave://flags are in the Default position.
  3. I suspect this is where my issues truly lie. Clearing browser data noticeably improved launch time of Brave browser, reducing the time the browser is frozen to roughly ten seconds, or less – which is a marked improvement over the 30-60 seconds it was taking to initially open Brave. Will try a completely fresh profile after some further testing with Hardware Acceleration disabled.

Thank you for these further suggestions, sir.

@brianoflondon,
Would you be willing to run a test for me, by downloading our Beta build (this will not interfere with any of your current Brave installation data) and seeing if you get different results?

1 Like

Downloaded Brave Beta and without my profile data or any extensions it loads immediately.

If I have to rebuild all my profiles, so be it… just let me know what to do.

@brianoflondon,
If you do, the task will be easy but before we do that, it’s likely that this issue is directly related to the browsing data stored in your profile. Can you try two more quick tests for me before we go ahead and migrate your information over?

  1. Can you try right-clicking on [any] site, then go to Brave --> Clear CSS rules for all sites and see if that makes any difference?
  2. Can you try clearing your browsing data for All time? I know that may be a bit annoying but it may shake some things out and fix the browser performance issue.
2 Likes

I think this may have worked!

I cleared the CSS Rules for all but that didn’t make a difference on its own.

I cleared all the default selected items but not the final 4 (I DID NOT CLEAR auto-fill, passwords (none there) site & shield settings or hosted app data)

After that clear down, Brave shut down and snapped open like it used to!

Thank you!

2 Likes

I’ll add one thing, if I didn’t have all my passwords in 1Password this would be a monumentally annoying recovery. Even the browse bar doesn’t auto fill my favourite sites.

Just tested the same thing and its night and day difference. Performance is great. I wonder why this is the case. Why would private mode cause this big of a performance boost?

@br0mega,
It may be due to the fact that some cached browsing data is conflicting w/browser performance. You may want to try clearing your cache/browsing data in your main profile and see if this improves performance as well.

Thank you for the recommendation. I cleared the history and did another test. Still, the same problem. Choppy slow performance on normal, and great snappy performance on private.

@br0mega,
May also be a particular extension installed in your main profile? Can you try disabling extensions and see if it improves performance at all?

Hi, we are the creators of GoCharting.com our users generally complain about the platform performance in Brave. On looking into the matter, we realized that Allowing Fingerprinting improves the performance dramatically. So how can we achieve the same level of performance with the default Brave settings. Can you look under the hood and let us know what component needs to be tweaked to ensure performance under default Fingerprinting settings

macOS Mojave 10.14.6 (18G6020)

Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36

I followed some of the above instructions:

  1. Disable sync – No effect
  2. Clear browsing data – No effect
  3. Disable sync in brave://flagsNo effect
  4. Reset settings – No effect
  5. Disable “Use hardware acceleration when available” – Fixed!
1 Like

For me it has not solved, used above mentioned beta version. Also changed profile and changed above suggested option.

I in live market for every 10-15 min I need to warm up each tab. I used only 4-5 tab. I have taken video but not able to upload it here , as i don’t have permission.

Yes for charting site it gives slow performance. Cache and rendering not in sync.

I am having the exact same problem

Having same problem on a few websites, always with this one:

https://online.citi.com/US/login.do?locale=en_US

takes about a minute to completely load. Chrome loads it instantly.

So far I have tried:

  1. Disabling Hardware acceleration
  2. Brave --> Clear CSS rules for all sites
  3. clearing browsing data for All time
  4. turned off all extensions

none of this helped.

If I open a New private window and go to the above website Brave will load it instantly,
(hmmm… this happened once, but I can not repeat now…private window is slow too).

brianoflondon had some luck (I think) with the above… but not helping for me.

I’m using:
Version 1.13.86 Chromium: 85.0.4183.102 (Official Build) (64-bit)

Any other suggestions?

Thanks,
Curtis

PS this has been going on for at least 3 months…,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.