Brave is very slow

So I leave my PC on during the day whilst I’m at work. When I come home I try to use Brave. Every time I open Brave it loads web sites very slowly and once the site is loaded there is a lot of buffering going on. The only thing that corrects this is if I reboot the PC. I really don’t think I should have to reboot my PC every day. I’ve tried to clear the site data. Restarting Explorer. Even created new profiles. nothing helps.


Hey @ashencrumbs, few things to try here:

1 - Disabling active extensions one by one until you notice a difference in performance – extensions are often the primary culprit for slowdown.
2 - Disable hardware acceleration from the Settings > System page.

Well, I disabled all of my extension as well as hardware acceleration. Same problem. I’m still waiting for to load. It’s been over 3 minutes.

1 Like

So if you were to reboot your PC right now, and use Brave normally, how long would it take until the browser started slowing down? Or have you never noticed it slowing down during usage?

If I restart now Brave will run normally for hours. As I said in my first post. It’s seem that only when the PC has been sitting idle for several hours and I begin to use it again that Brave slows down.

It may be an extension or website running in the background, but you said disabling extensions didn’t make any difference. Do you have any specific websites open when you see this issue occur or does it seem to happen regardless of that?

It happens with all websites. I tried to load and it was taking so long to load that I gave up and just rebooted the PC. After the reboot the site loaded quickly.

I was thinking that it might be a problem with the OS acting strangely but I opened Chrome and had no problems

Hmm, very strange. Going to ask a few team members if they know what might cause this. Thanks for your patience.

I was just curious if there is any update on this post. I am having similar issues, except… Mine is slow ALL the time. I have rebooted multiple times and it is only slow on Brave, which saddens me, I love the Brave browser. On multiple speed tests I am averaging around 0.5 mbps download speed on Brave but around 17mbps on both Edge browser and Chrome. In fact, I am writing this on Edge because Brave wouldn’t even load it.

If it helps this is my Version info:
Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (32-bit)

Thanks in advance!

I found and disabled hardware acceleration and this did help, enough to make the Browser be able to load webpages, but the speed tests show around a 4.4mbps download speed, regardless of which extensions are on or off or all off. Hope this helps.

Other browsers, Edge and Chrome still tested in the 17 mbps range f.y.i.

Can you try creating a new browsing profile (Menu --> Create new profile) and see if the browser runs better when using this newly created profile? I’m wondering if some there are some “bad bits” stuck in your cache that are causing the slowdown.

I created two new profiles and the problem remains.

I’m having the same issues too.
I only have a couple extensions going - screen capture, google translate - and I do normally have a good number of tabs going - maybe 6-10 at a time.
Its to the point where some pages seem to time out because they’re taking so long to load. Need to refresh the page and suddenly its there.
And its not the internet - our connection is giving us 40mb down on average.

I just turned off the hardware acceleration, so i’ll test and see if that helps.

I’m also wondering if its more predominant on tabs you open the navigate away from? LIke I’ll open a link in a new tab and not go to it yet while I continue on the original tab. I’ve seen a few of those error out then refresh again when I go to the tab…

But overall, running a lot slower than chrome over the past 3-4 weeks I find.

It’s happened with me about 2-3 days ago, at my phone actually, didn’t install anything new like extensions or something else. Before it was totally fine, but now if I click on some Brave icon which were added by me before on my screen, it’s just empty Brave page for about 60-90 seconds :worried:
Android, OnePlus 7t, everything updated.

my bookmarks html file is 21.4mb with chrome and safari i was having a lot of problems with cartwheels (spinning wheels) every time i try to add a bookmark edit do anything with bookmarks i tried another browser i can’t remember same but this browser bookmarks were super fast and worked perfectly but now every time i open a new tab it’s super slow i have to wait 50 seconds of intermittent cartwheels before the tab works and i can’t type in an address etc i tried creating a new profile and that fixed the problem everything was instantaneous and i imported my bookmarks to that profile and it still was slow but a lot faster like 5 second wait every time after opening a new tab and then i started adding some more bookmarks and it got slow again the new profile is now like 50 second wait on every new tab (if i have no bookmarks then it’s fast)

if i create a new tab in private window, though, it’s instantaneous and fast

also not in private window, if i follow a link to a new tab it’s instantaneous and fast, it’s just if i create a new empty tab it takes 50 seconds of spinning wheels before it works

I also have issues since a couple of days, if I close Brave and I put it back on, the websites takre around 5 to 10 seconds to reload,and after that everything works fine. Every time I put it off and back on it needs this time to start up… weird, cus it is very annoying and I would like to keep using Brave

Yeah same here to the point its unusable and I have a plenty of system resources I run this on. 24 thread CPU with 64GB ram on M.2 SSD’s, 2 GeForce 1080 TI’s running in SLI. Not bragging, just making a point that it’s def not my system. Run’s terrible. Slow loading and choppy. No clue it just started happening today.

1 Like

Yeah, here too. I’ve made a new instalatiion of Windows and after I downloaded Brave again it is soo slow, I think it didn’t had this profile thing before too, I’ll try downloading an older version idk