Brave is very slow

Just tested the same thing and its night and day difference. Performance is great. I wonder why this is the case. Why would private mode cause this big of a performance boost?

It may be due to the fact that some cached browsing data is conflicting w/browser performance. You may want to try clearing your cache/browsing data in your main profile and see if this improves performance as well.

Thank you for the recommendation. I cleared the history and did another test. Still, the same problem. Choppy slow performance on normal, and great snappy performance on private.

May also be a particular extension installed in your main profile? Can you try disabling extensions and see if it improves performance at all?

Hi, we are the creators of our users generally complain about the platform performance in Brave. On looking into the matter, we realized that Allowing Fingerprinting improves the performance dramatically. So how can we achieve the same level of performance with the default Brave settings. Can you look under the hood and let us know what component needs to be tweaked to ensure performance under default Fingerprinting settings

macOS Mojave 10.14.6 (18G6020)

Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36

I followed some of the above instructions:

  1. Disable sync – No effect
  2. Clear browsing data – No effect
  3. Disable sync in brave://flagsNo effect
  4. Reset settings – No effect
  5. Disable “Use hardware acceleration when available” – Fixed!

For me it has not solved, used above mentioned beta version. Also changed profile and changed above suggested option.

I in live market for every 10-15 min I need to warm up each tab. I used only 4-5 tab. I have taken video but not able to upload it here , as i don’t have permission.

Yes for charting site it gives slow performance. Cache and rendering not in sync.

I am having the exact same problem

Having same problem on a few websites, always with this one:

takes about a minute to completely load. Chrome loads it instantly.

So far I have tried:

  1. Disabling Hardware acceleration
  2. Brave --> Clear CSS rules for all sites
  3. clearing browsing data for All time
  4. turned off all extensions

none of this helped.

If I open a New private window and go to the above website Brave will load it instantly,
(hmmm… this happened once, but I can not repeat now…private window is slow too).

brianoflondon had some luck (I think) with the above… but not helping for me.

I’m using:
Version 1.13.86 Chromium: 85.0.4183.102 (Official Build) (64-bit)

Any other suggestions?


PS this has been going on for at least 3 months…,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.