Brave doesn't download files after specifying download location (Pop! OS 21.04)

After a recent OS update in Pop! OS which seems to have updated the system dialog boxes for things like file pickers, downloads no longer work in Brave.

Description of the issue:

If I have “Ask where to save each file before downloading” enabled in Download settings, when I go to download any file, it asks for the location to download to as normal. However, after clicking “save”, I would expect the download to start. Instead, nothing happens. If I disable asking for download locations, files download to the default location just fine. So the problem seems clearly to be that the file picker isn’t able to transmit back to the browser the location of where to put the file after the latest OS updates.

How can this issue be reproduced?

  1. Install latest Brave according to instructions online (using PPA for Ubuntu).
  2. Fully update Pop! OS 21.04 with most recent updates as of May 24, 2022
  3. Try to download a file.

Expected result:

File actually downloads after selecting download location.

Brave Version( check About Brave):

Version 1.38.119 Chromium: 101.0.4951.67 (Official Build) (64-bit)

Additional Information:

N/A

Today I updated Brave to 1.39.111 and the same issue persists.

1 Like

I have tested whether other browsers are affected by this issue. Downloads in Firefox work fine, while Chromium has the same issue – since Brave is based on Chromium it seems this is a Chromium/Pop-OS interaction issue. Firefox still uses the system file picker for download locations though, so it seems it’s not the file picker itself that is the issue.

1 Like

One more update: in Brave, there’s no issue with the system file picker if selecting a file for UPLOAD. Only downloads are affected by this issue.

1 Like

I have the exact same issue.
I’ts worth to mention that sometimes it worked depending on the location i choose with no specific criteria.
[Version 1.38.119 Chromium: 101.0.4951.67 (Official Build) (64-bit)](https://brave.com/latest/)

@ravager2928

A simple text file for you to download. The contents are one word: “test”

testFile.txt (4 Bytes)

This was interesting. I enabled “Ask where to save each file before downloading”, then tried to download the file. The first time, the default location it selected was the previous automatic download location (when the ask option is off). This successfully downloaded the file. Then, I tried to download it again to another location, and it didn’t work. I then tried to download it to the default location again (with the “ask” option still on), and it didn’t work.

Same here. There is no rule for when it works or when it doesn’t. But out of 10 downloads it works only if i don’t choose the location to download to. (Linux 22.04 LTS).
Also, i noticed that when the path gets longer this happens way more often always all the time. On contrary, sometimes when i change default location to first level under home /home/<usr>/*

@ravager2928

I wonder if the problems are related . . .

Take a look at:

@289wk: The first issue seems like it may be related. Certainly there’s something up with the way information is passed from Brave to system file handlers (or maybe vice-versa? Though specifying uploads works fine).

1 Like