Downloaded files not going to correct folder

I have my downloads set to Downloads folder in Internal Storage and most files download correctly to this folder

However, for some reason, when I download an .srt file they don’t go into my downloads folder but instead I find them in Movies folder. I’ve tried again and again with similar results.

Application version

Brave 1.38.119, Chromium 101.0.4951.67

Operating system

Android 11; Build/RP1A.200720.011

MIUI Global 12.5.7

MIUI version

Stable 12.5.7.0(RGGMIXM)

Android version

11 RP1A.200720.011

Ref.:

Possibly . . . look thru your Brave Browser > Settings, for something that looks like it would re-route or re-direct a media file.

Perhaps some auto-play feature requires a media file to download to a certain folder.

Or an Extension is involved.

Nothing I can find. On Mobile so have no extensions. It doesn’t send the .srt file to a program to open, it just downloads it into this folder

@spiracles

If you are feeling energetic, try to disable the influence of the website . . .

This section - because it allows Brave Browser to start up without a burden:

In a Brave Browser > New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

This section - to clear away cache and cookies:

Go to: brave://settings/clearBrowserData

For tab Basic - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

This section - because Google things:

Go to: brave://settings/shields

  • Disable: Auto-redirect AMP pages

If you have an older version of Brave Browser, try:

  • Disable Enable De-AMP at brave://flags

This section in order to keep control in your court:

Go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

‘And for good measure’ - go to: brave://settings/security and Disable: Use secure DNS

@spiracles

Maybe try . . .

IDM

https://play.google.com/store/apps/details?id=idm.full.free&hl=en_US&gl=US

ADM

https://play.google.com/store/apps/details?id=com.dv.adm&hl=en_US&gl=US