Brave Browser blocks MetaMask

<---------Delete this line and everything above before posting---------->**

Description of the issue: Since today every single website I’m usually using which connects to MetaMask is not connecting to MetaMask any longer. Instead, the Brave Wallet does pop up. I already tried every single option in the wallet setups. Set Standard ETH wallet to “extension” does not help either.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

WIN 10

Brave Version
[Version 1.50.114 Chromium: 112.0.5615.49 (Offizieller Build) (64-Bit)]

Additional Information:


Yea this little “feature” needs corrected like yesterday.

1 Like

Having the exact same issue. Have had to resort to getting everything set up on firefox. Hoping the Brave folks will fix this; forcing wallet connections is not the way.


this is beyond annoying I cant work with brave browser anymore!
Please fix this. ASAP


The same sh*t.
It so annoying


This is a horrible feature! Nobody wants your freaking brave wallet shoved down their throat.

I am trying to log in normally to my web3 websites using my metamask and I’m getting redirected to the brave wallet onboarding page. The website then throws an error and I have to work around just to connect.

I swear to god anymore of this forced marketing and I will freaking leave to Firefox

Cut this sh*t out!

1 Like

It’s fixed in V 1.50.119 go to Settings → About to force an update

I wish it was fixed but I just updated and Brave still does the same thing - goes to Brave wallet and not Metamask. What I have found is that, after that first attempt which goes to Brave wallet, I refresh the page and then I can connect with Metamask. This is a serious issue and needs to be addressed pronto!

It is not fixed, nothing has changed

Ctrl-Shift-R to force a refresh of the webpage helps. I need to do that on each page with a new visit, after that I have no problem with that page anymore.

Unfortunately, this doesn’t work for me.

I’m on the latest version of Brave, refreshed the pages/cache a bunch of times, but still it displays the Brave Wallet page whenever I want to connect to web3 sites via MetaMask.

Is there any other workaround?

@karateschnitzel Please visit and click Connect beneath Basic Actions. You’ll be prompted to open your wallet; you can simply disregard this. You should be prompted to open whichever wallet is configured as your default in the Wallet settings under brave://settings/web3.

I just switched my own settings to “Extension”, refreshed the test-dapp page, clicked Connect, and was greeted with my MetaMask sign-in view.


Thanks for the feedback!

I took all your described steps and unfortunately I still get redirected to the Brave wallet page (brave://wallet/crypto/onboarding/welcome) whenever I try to connect MetaMask via the link you shared.

Invalidated the Browser cache multiple times and restarted Brave as well. Still the same issue :frowning:

Would you be willing to hop on a call/screenshare briefly, to look at this issue together?

When would it work for you?

It is not the solution. 1st why would I do that? It should just work regardless if I visit website 1st or 3rd time. 2nd, it just doesn’t work even if I visit website 2nd time. It is just shameless way to force users to use brave wallet instead of Metamask and If it doesn’t change within a short period of time, I will just dump Brave for Chrome.

These features absolutely should just work, but software is unfortunately more complicated than that at times. In this case, it’s entirely possible a third extension could be involved.

In our testing so far, uninstalling Phantom (another wallet) has resulted in a restoration of MetaMask use. That doesn’t mean the problem is definitely with Phantom, but it does mean there is something fairly complicated in play.

We’re working hard to understand this issue, and deliver a quick fix insomuch as it is in our ability to do so. I do hope to have a more substantive update for you soon.

@karateschnitzel Can you confirm if is still an issue for you? I’m asking as I saw your comment that it’s working for you now but then I saw it deleted. Not sure if you deleted because issue still happening?

Unfortunately, it’s not resolved. Thought so at first, but then it came up again.

1 Like

Darn, ok @karateschnitzel. Btw, did you ever manage to schedule a time for a call/screenshare with @sampson? I know you responded to ask when would work with him last week, so tagging in both of you now in case hasn’t happened and able to maybe work together to figure it out.