MetaMask wallet will not work with Brave since 07/27 ish

Starting about a week or 10 days ago I started to not be able to sign into all of my platforms using Brave browser. Just confirmed that It’s a possible Brave browser issue. MetaMask says not their wallet. Please tell me if the maybe some setting was changed with how Brave interacts with the chrome wallet extensions during the last build. I am having to set up everything on Firefox because I am stuck and have no ability to use Brave currently.

Thank you

There is an open Github issue, hopefully developers will fix the issue anytime soon as a lot of users are reporting issues with MetaMask.

Until a fix is found, you could try a workaround provided by @Luckys, it worked for a few users.

Hi managed to sort mine by going into Brave settings and turning off (Load crypto wallets on startup) then restarting browser hope this may help some of you.

it worked for some of us try it!

Original thread → Metamask Stop working with Brave Browser.

1 Like