Brave Wallet - Can't log in or enter seed phrase / restore account

A number of times I’ve been on sites requiring me to connect my Ethereum wallet, which I use MetaMask as an extension in Brave, but when it tried to connect the Brave Wallet pops open and I’m prompted to put in my password. It looks like it’s my MetaMask, so when I’ve tried to put in my password it doesn’t work (I also tried my account password as well).

I then tried to then click on “restore account” but nothing happens.

I haven’t been able to find any support on this topic in the community so I’m starting a thread. Any help would be most appreciated as I now need to go to my other browser anytime I need to connect a website to my MetaMask.

My browser is up to date with the latest - Version 1.1.22 Chromium: 79.0.3945.79 (Official Build) (64-bit)

Pls see screen shot


This is a known issue that the team is currently addressing:

Thanks for the reply! I hope it can be resolved, as it’s a pain in the butt to have to jump to chrome to do anything ETH related via MetaMask when all I really wanna do is use Brave!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.