Brave enforcing Brave Wallet over Metamask

When interacting with a dapp, whenever I try to sign any login request selecting Metamask on the dapp, Brave Wallet pops out instead of Metamask. I’ve reseted the Brave Wallet and now it redirect to Brave Wallet creation.

My default Ethereum Wallet is set to Extensions.

I’ve never changed browser configs for a while and after last week’s update, I’m getting the issue described above. The issue t’s annoying.


This issue is beyond annoying when your in heavy galxe/quest/nft mode, its almost become unusable because of this.


Yeah, we don’t want to use Brave Wallet and the team seems to be ignoring it…

This is driving me crazy, I swear. I have to start every single signature at least twice and refresh my page and open MM for this to work. I just switched from Chrome to Brave and this is really making me miss Chrome. I hope they do sth about it and I hope they do it fast


Same thing happens to me. I dont want to use youre stupiid wallet, i want to use metamask, if this doesnt get fixed in deleting this browser, it supposed to make things easier to people and now its just driving me crazy

1 Like

Same issue

Why is this happening all of the sudden please help

Metamask won’t queue transactions or anything yet shows actively working in the extension bar when clicking into it. Brave opens a new tab with brave://wallet/crypto/onboarding/welcome in the URL. I dont want your wallet. I want to use MM!

Please fix please fix quickly

1 Like

Is your browser up to date? brave://settings-help
Someone with a similar issue fixed it by updating their browser.

Also make sure your Default Ethereum wallet is set as following:

Thx for the response and yes mate, it’s updated and configured… double checked everything I could before opening the thread. This is the worst bug ever, missed some snipes because of that…

I’m experiencing this exact issue but have found a work around - hit refresh on the page and then Metamask will connect, not the Brave wallet. Hopefully this helps.

1 Like

Sure it does, I described it before, but it’s still super annoying and I hope they will fix it soon. Maybe it has something to do with their safety block function. It worked better when I disabled it

Where is this ‘safety block function’? Couldn’t find it by myself.

Do you have the Phantom extension enabled too? It seems MM and Phantom are conflicting somehow after an update on their end, thus Brave Wallet opens instead.

Apparently, setting the Default Wallets to “None” would fix the issue.

1 Like

This one at the top, “shields”.

Hi @Fumeterre

We now have a fix for this. There seemed be an issue for when users had Metamask, Phantom and Brave Wallet on their profile. We have now fixed this edge case. It’s working on nighlt and beta versions and will soon make into main release of the browser. I will update this thread when its here.

You can follow issues here


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.