Metamask Stop working with Brave Browser

Hi, Iv encountered a problem signing in with MetaMask using the Brave brower recently. I double checked with Chrome and also using brave on Mac, which worked. however it did not on Windows. Is it a known issue, or is there annything i can do?

This is what it says in the metamask when i try using anny Dapp

“We noticed that the current website tried to use the removed window.web3 API. If the site appears to be broken, please click here for more information.”

Cant find annyyhing about it online. Plz

3 Likes

Same here.
macOS 11.4
Brave
Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (x86_64)

MetaMask 9.8.2

2 Likes

same here + it can’t load uniswap, sushiswap, etc…

2 Likes

Same issue here on Win10 latest updates, only have issue when using brave. chrome works fine.
I tried to remove metamask from brave and reinstall/restore wallet. no dice

2 Likes

yeah, same here. i hope we get a uppdate soon!

Any updates on this? This is pretty inconvenient. Does it definitely have to do with the Windows 10 update? This is infuriating.

I have the same problem with metamask.

Is possible to downgrade to a previous version of Brave?

Thanks

Hi all, thanks for reporting. @Luckys @pogo11 @bjgingrich11 does it work for you in a private window? What extensions do you have?

Hi @steeven.

the problem apparently is with the web3 pages from metamask they recommend to use another extension called MetaMask Legacy Web3. But the problem was not solved.

In my case I just downloaded and installed the brave browser Nightly Version 1.29.26 and metamask worked correctly.

I will use this nightly browser for a moment because I have to do some transactions today.

1 Like

Oh thank goodness it’s not just me I was going crazy the past 2 days since the last update.

I’m on Mac latest version using Brave latest version.

I tried the 2nd Metamask Ext. for Web3 pages but it still dose not work.

I was able to use chrome and had no issues using MetaMask so it’s something def wrong with the last Brave update that came out. I also want to know if there is a way to revert to an older version of Brave.

1 Like

Hi managed to sort mine by going into Brave settings and turning off (Load crypto wallets on startup) then restarting browser hope this may help some of you.

it worked for some of us try it!

6 Likes

Just tried it, but still not operational. Thanks for the suggestion.

This helped me! Thank you!

1 Like

Just tried this and it worked for me. Thanks!

1 Like

Same happened to me. Please a fix is needed. I don’t want to go back to chrome. Anyway, Luckys advice worked just fine.

Thanks mate! Worked!

1 Like

I’ve turned off Load crypto wallets on startup and now I can manually connect with wallets on Metamask BUT the connection cannot appear on DEFI webpages (eg.: https://debank.com/). Problem partially solved.

1 Like

This solution also worked for me, great Tip Thank you.

This worked for me. Thank you so much.

Heart attack averted.

Worked! You’re a lifesaver!