Autoplay was blocked on this page - not actually blocking autoplay


#1

On this page:

I get the notification that “Autoplay was blocked on this page” but the video does indeed autoplay.


#2

I can’t reproduce this one on macOS on Dev or Beta in either the video on the right or the ones after scrolling on page. Let me try Windows.


#3

@bloodguard, dope name.

Was it this video here that was autoplaying?

Also what is your autoplay currently set to?


#4

I believe @bloodguard you are experiencing this issue which is fixed and should be available in the next build


#5

I’m set to block the scourge that is autoplay. The video in the screen shot has been replaced with another (amazon 15/hr wage) and it still autoplays. And I still get an icon in the address bar saying autoplay has been blocked.

I can get it to stop autoplaying by installing and enabling the “Disable HTML5 Autoplay” extension.


#6

I’m not sure it is. I have autoplay disabled (blocked). It pops up that it blocked the autoplay. But it’s not stopping it from autoplaying. If I install the “Disable HTML5 Autoplay” extension then it’ll stop playing.


#7

What do you see in autoplay setting? Is that site added to the allow list?

By default all autoplay is blocked unless its allowed. If you have the site listed in Allow you need to remove it so that it doesn’t play. You don’t need a third party extension to do it.


#8

Hi, all autoplay disabeling worked very well in the former version. The Chromium based version seems to have a problem blocking HTML5. E.g. autoplay of youtube videos is not blocked anymore. Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit). Besides this, my favourite browser!


#9

Hi @elmagnifico,
I think that’s expected since YouTube is whitelisted. You need to:

  1. Visit https://youtube.com
  2. Click on site settings (padlock icon at URL bar)
  3. Click Site Settings
  4. Change Autoplay from Block (Default) to Block

It should block them properly now.
Thanks
:slightly_smiling_face:


#10

Hi eljuno, Thank you very much for the quick response. No website is whitelisted. Autoplay is set to Blocked in the Content Settings. No exeptions. Anyhow, I followed your advice. Youtube does still autoplay although youtube.com:443 is now explicitly listed under the Block section of Autoplay. I faced the not working Autoblock also on other websites (names I do not remember),


#11

@elmagnifico,
Just to confirm, in content settings, did you enter https://[*.]youtube.com:443 - in that exact format?


#12

Hi Mattches, Yes I have added manually as you suggested. Still not blocked.


#13

@elmagnifico, sorry for the late response.
Since this thread was opened we’ve updated Brave Beta to v0.59.28
Can you check and confirm if this is still an issue after updating?


#14

Hi Mattches, I have updated to v0.59.28. Stll the same problem. Best regards


#15

@elmagnifico Could you try this?

  1. Click on the profile icon next to the hamburger menu
  2. Click on Manage people
  3. Create a new user profile
  4. Open YouTube, play any video and then follow the steps that @eljuno mentioned in Autoplay was blocked on this page - not actually blocking autoplay
  5. Close the tab and open a new tab and load YouTube and check if you get the Auto play blocked message on the URL bar?

#16

Hi,

I followed your instructions and no there is no Auto block play message on the URL bar.

Best regards


#17

When you click the padlock icon in the address bar, do you see a message similar to this:
image


#18

Yes, I see “Autoplay” “Block”.


#19

Is there any way you could provide a screen recording of this behavior as you see it? See this topic here on Community for free/open source screen recording resources if you don’t have a way to do this already.

If you’re willing, I’m interested in seeing a recording of you visiting Youtube.com, attempting to stream a video and YT autoplays (even though it shouldn’t), and your Shields settings as they are displayed in the Shields panel.


#20

Ok I think there might be an issue here. There’s a few things happening here

  1. Auto play block for site settings doesn’t take effect on new videos which is a regression i believe
  2. Even after setting the site to block autoplay it still plays, you have to manually block again from site settings in URL bar
  3. Can’t use wild characters to add to block all videos from a domain so https://[*.]youtube.com:443 won’t actually work because Youtube uses youtube.com/watch/* so TLD+1 wont be applicable here
  4. The steps @eljuno mentioned above only blocks the current video and not all videos on YT, so if you block on a video and then navigate to YT home page and load another video setting wont work

This could be specific to YT or may be all whitelisted sites but I logged an issue for this to be fixed. You can track the issue here