Autoplay not blocking videos from playing

Videos play for some sites automatically start playing even though autoplay is set to “block”. Other browsers (e.g. Firefox) seem to block the behavior.

Here’s an example:

I’ve confirmed that the site settings for that specific site indicate that autoplay should be blocked. It just doesn’t seem to actually stop the behavior.

Really really like this browser otherwise, hoping there will be a fix for this issue.

Description of the issue: Autoplay is set to blocked, but does not work on at least some sites.

How can this issue be reproduced?

  1. Go to
  2. Observe video automatically playing
  3. Become sad

Expected result: Video player loads but does not automatically start playing a video.

Brave Version: 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit) (Windows / Desktop)

Additional Information: The only thing that seems to stop the video from playing is turning on the Scripts shield for the page…but seems like a bit of a sledgehammer workaround.

quick answer: add the AutoplayStopper extension —

detailed answer / some history: Brave is built on Chromium. (You may already know this.) Until mid/late summer 2019, Chrome users (and hence Chromium and Brave users) could edit a flag that controlled autoplay policy. Mid/late summer 2019, Chrome / Chromium (and hence, Brave) deprecated this flag. The explanation from Google: enabling advertisers to “engage” browser users. The result: users no longer control autoplay. I installed the AutoplayStopper extension to minimize this “engagement”. It’s worked well for me. When this topic comes up in discussions, I’ve not seen any negative comments about AutoplayStopper.

Mid-May 2020, a Brave moderator suggested Brave may have a fix in the works. Maybe.

Installing AutoplayStopper fixed the problem of uncontrolled videos for me and for others. YMMV.

Interesting. Thanks for sharing @redbike9 . It does appear maybe this will be fixed with a forthcoming 1.11.x release. Appreciate your help. I’ll download the extension you recommended until then!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.