Not possible to set autoplay to block

Description of the issue:
Not possible to set autoplay to block

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Open, click lock beside URL in browser bar, click site settings, scroll to video autoplay, set to block

Actual Result (gifs and screenshots are welcome!):
Selecting block reverts to allow

Expected result:
Selecting block sets value to block

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
W7, Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

1 Like

Thanks for reaching out to us with this.
This isn’t the fist time I’ve seen this behavior we’re currently trying to figure out what the issue is.

It seems that the setting will reset at some point no matter what you try to do. To confirm, if you click the lock icon, then go to Site settings --> Autoplay and set the setting to Block here, it seems that it does, as you describe, revert back to Allow but even so, returning to YT and refreshing the page – autoplay is either blocked or, if still allowed, clicking lock icon, then setting autoplay to Block again in the dropdown will block autoplay.

If you could/wouldn’t mind taking a short screen recording of the behavior, it would help us document the issue and build a case against it so we can get the error resolved as soon as possible.

@Mattches Hi,

Are you aware of this thread? Unable to block autoplay (setting don't work)

It seems it’s related to a hidden autoplay whitelist.

There’s a screen recording of the same behavior at the link @Zook provided

What’s interesting is that the block actually works once, even though it says “allow”. However if you close the tab and open a new one, future tabs the block is no longer effective.


Hi team, what happening with this? What’s the logic here?

Well – seems like we have a bug :slight_smile:
I think the bug is two fold:

  1. Autoplay default value should display: Allow (default) when the site is in whitelist, otherwise Block (default)
  2. Autoplay content setting page should reflect current value instead of reverting to Allow constantly

Will be digging into this further with the team.

Awesome, appreciated!

1 Like