Autoplay was blocked on this page - not actually blocking autoplay


Hi, I have attached the ths shield settings, the block setting and a recording of autoplay.



Using latest release (now v0.59.34 at the time of writing this), I took the following steps to block autoplay on Youtube:

  1. Visit YT, stream video - Video plays automatically (default settings are to block Autoplay, this is a part of what @sriram mentioned above)
  2. Click the lock icon in address bar --> Site Settings
  3. Set Autoplay option from Block (Default) to Block
  4. Reload when prompted on YT

This is the same in Beta for me as well. Given that we’ve just updated, would you mind trying the above steps (you may want to reset permissions for the site first - it’s the very last option in the Site Settings menu in your image above)?


Hi, I have tried version Version 0.59.34 and the beta. Yes, they behave the same way. I reset the permissions, set the Autoplay option to Block and Reloaded. The current video was not autoplayed anymore. But at the end of the current video the next in line is autoplayed and so on. Ok, I could disable the Autoplay on the youtube site itsself (blue switch upper right corner), but after clearing the browser history this switch is reset to Autoplay again. In Chrome I installed an extra app to disable HTML5 autoplay (see picture) and it behaves like expected. It overrides the blue switch Autoplay setting of the youtube page and and blocks the consecutive videos under all circumstances. disable%20HTML5%20app My first idea was to install the same app in chromium based Brave. But when I tried I got a warning that this app has access to all websites and might compromise the privacy intention of Brave. So I did not install this app in Brave. And as I wrote in one of my earlier messages, the old non-chromium based Brave autoblocked youtube reliable (even the consecutive videos) without an extra app.


Thanks for clarifying and testing that for me.
It looks like I’m seeing the same behavior - Autoplay is blocked for the first video, then if played, the YT Autoplay function kicks in and is not blocked. Further, the next video loaded will also not have autoplay blocked. Note that if you refresh the page after the next video in queue loads, autoplay is blocked.

I’ll likely file a new issue for this so the devs can review. Appreciate your patience and willingness to work this out!