Are there any Brave 'security' settings that can affect the 'calling feature' of Google Hangouts / Call Phones from GMail?

Since the last time I quit and reloaded Brave, phone calls I make from GMail (or from Hangouts) all have resulted in the parties called not being able to hear me.

Is there a default setting in Brave (i.e., one that is activated by default from a browser reload) that might interfere with the operation of that feature?

Or a ‘shields’ setting?

Thanks.

Brave Release on a Mac (OS Mojave)

1 Like

@mk7z,
I believe you’ve asked this before.
You should be able to do this without issue as long as you have

  • Given the site proper permissions
    • Camera, microphone, etc
  • Enabled the built-in Hangouts extension in Settings

Thanks, the problem I have at the moment is that I seem to have all the settings correct, but the issue is occurring anyway.

So I wondered whether a recent version of Brave (Release) may have changed a default (and/or shields) setting that might be affecting Hangouts.

The “permissions” you’re referring to are the same ones that appear directly in GMail (or Hangouts) when you try to make a call, correct? That is you are prompted to enable access to the microphone if it’s not already enabled.

I’ve also checked settings in Mac OS’s System Preferences (“Security & Privacy”), and Brave is shown as having “access [to] your microphone.”

What else do I need to check?

image

image

1 Like

@mattches Just remembered something. In the original discussion of problems occurring with Hangouts (Call Phones from GMail) calls, wasn’t it determined that Shields need to be turned ‘off’?

If so, maybe that’s what’s causing my current issue. But I didn’t turn them back on. That’s why I asked about whether an update, etc. to Brave may have defaulted them back to being ‘on.’
. . . . .
Assuming the above is correct, I reported this (Report a Broken Site) just to possibly find out which particular shield(s) need(s) to be turned ‘off’ for Hangouts calls to work properly – or whether they all need to be ‘off.’

1 Like

@Mattches My hunch seems to have been correct. First call I tried after disabling all shields worked.

I would like to find out which shield(s) is/are the one(s) that need to be disabled, so that I (presumably) don’t have to disable all of them.

Is that information available?

Also, clearly something not user-activated is turning the shields back ‘on.’ Would like to also find out why that’s happening as well.

Thanks.

1 Like

It’s likely the Fingerprinting protection causing the issue in Shields – not entirely sure though because everything is working on my end.

What do you mean Shields are being turned back on?

1 Like

@Mattches

> What do you mean Shields are being turned back on?

I was referencing my earlier post here (“But I didn’t turn them back on.”) – i.e., that I had not reset my shields settings. They were turned back ‘on’ (I assume, automatically, definitely not by me doing anything) after I did a system restart (reboot).

I’m seeming to recall now that when GMail is opened in a private tab, the shields ‘off’ setting won’t be remembered (i.e., the ‘shields on’ default will kick in following the restart).

I don’t recall that having occurred through other system restarts in the recent past, though. (IOW, the calling problem didn’t occur even after a system restart and I never did anything with ‘shields’ after those restarts. So that’s a bit mysterious, but hey…)

1 Like

@mattches Just checking because I seem to be back in the situation of having to reload GMail with shields off – otherwise the party I’m calling can’t hear me – something I haven’t had to do in recent memory.

Are you on a Mac and calling with shields ‘on’ without any such problem?

Also, are you in a Private tab when you use Hangouts or Call Phones from GMail?

If I can’t figure out what’s going on, I think I’ll have to just use Hangouts in a regular (not Private) tab, to avoid always having to turn shields off (and load Hangouts/GMail twice).

Thanks.

1 Like

@mk7z,
Can you please fill this out exactly so I can try and reproduce the exact behavior you’re sseeing?

@mattches Done. Hope it’s clear.

Reproducing should just be a matter of:

  1. Open Private tab.
  2. Load either GMail or Hangouts.
  3. Shields on (should be on by default in a Private tab).
  4. Attempt a call from whichever app you’ve chosen (GMail or Hangouts).

If you experience what I do:

(i) the party you are calling will not be able to hear you, but
(ii) after turning all shields ‘off’ and making the call again, they will be able to hear you normally.

Thanks.

@mk7z,
Just tested this in both standard and private windows and had zero issues.

  • Started a meeting, Shields at default, Brave team member joined and we were able to hear and see each other without any issues.
  • Then, left the meeting (team member was still in there), opened a private window, clicked the meeting link to rejoin – I was asked initially to allow access to Camera/Microphone when I landed on the site. I clicked Allow then entered them meeting and was again able to hear/see/participate in the meeting without any issue.

If you’re not allowing mic/camera access, this is likely the reason for users not being able to hear you. If you have given the proper permissions, you may consider clearing Site data for hangouts/gmail and resetting permissions. Then try to make a call and ensure that you give the appropriate permissions to the site.

@mattches Thanks, but how does that explain calls working normally when I turn Shields ‘off’?

It seems to me that calling would not work at all if my mic setting wasn’t the correct one.
It does work, but not with Shields ‘on’.

I just tested it (inadvertently) this morning:

– Opened GMail.

– Placed a call, forgetting that in a Private tab my ‘Shields off’ setting from prior session would not be ‘remembered’ and GMail would default to ‘Shields on.’

– Party answered. I started talking. She could not hear me.

– I hung up.

– I turned Shields off (all off). GMail reloaded (automatically).

– I placed the call again.

– All normal.

@mk7z,
When you have your Shields up, can you show me what settings they’re configured to? A simple screenshot would work.

@Mattches From the current tab (community.brave.com) – I assume the settings are global unless changed (as they are currently in the GMail tab, where the Shields are ‘all off’)

@mk7z,
Can you confirm for me that when they’re on, that they have the same settings as shown here (defaults) for gmail?

@mattches Shields back up in GMail tab:

@mattches Maybe the line below (in the Shields ‘help’ doc) should be modified to advise that if site-specific Shields settings are changed while in a Private tab, those changes won’t be ‘remembered.’

If you change settings for a particular site, Shields will remember your choices, even if you change the global Shields settings.

That said, in your post yesterday you appeared to say that calling from GMail (or Hangouts) in a Private tab had posed no problems for you.

If so, I don’t know what conclusion to draw except that some setting that’s affected by Shields (one or more of them) being ‘up’ is certainly affecting my ability to use Call Phones from GMail in a Private tab, because when I disable all Shields I have no issues with being heard by the party I’m calling.

Particularly since the calls are going out through a ‘Google’ (privacy disrespecter) app, I’d really like to find a solution that doesn’t require me to have Shields down.

Thanks.

Hello all !
The Shield settings for a certain site will transfer over to a private window.
@mk7z, for trackers and ads blocked you have it set to aggressive. That is not default. Can you go to gmail/hangouts and set it to standard.

for trackers and ads blocked you have it set to aggressive

@Aa-ron Thanks, but are you implying that ‘trackers’ and/or ‘ads’ settings can affect the microphone?

My issue is that people I call from GMail or Hangouts can’t hear me if my Shields are up. If I turn Shields off, they hear me.

@mk7z,
Yes, that is exactly what he’s implying. I also did not notice that you had it set to aggressive. As @Aa-ron asked, can you please change it to standard and see if this changes the behavior?