Can't get 'Call Phones from GMail' to work in Brave Dev

bug

#1

After disabling all ‘shields’ (& also disabling ‘3rd Party Fingerprinting’ in Settings), Call Phones from GMail connects to the party I am calling but I don’t hear them.

Mic & headphones are both enabled.

What can I check next?

It’s something in Brave because the call goes through normally in Chrome.

Thanks.


#2

Are you doing this through Gmail directly or are you using the “Hangouts” site?


#3

Directly from GMail. When I experienced the issue a few days ago I also tried calling from Hangouts, with the same result.


#4

On Hangouts, I was able to make a call in Dev version without changing any settings. You must allow access to your microphone before the call can go through so make sure you’re doing that when prompted (or that you haven’t already had it blocked permanently).

When attempting through Gmail, you must allow device recognition before you can successfully make a call.


#5

Thanks, I haven’t seen the mic prompt in Brave (I know what you mean from Chrome).

Where is the access setting for that & the one to ‘allow device recognition’?

I don’t see either in ‘Settings.’


#6

Sorry for the late reply, quite busy today.
Device recognition (also referred to as Fingerprinting) is a setting in your Shields panel:

  1. Open Brave
  2. Navigate to gmail.com
  3. Click the Shields icon to reveal the Shields panel
  4. Change the Device Recognition setting to Allow all... as shown here:
    image

You should now receieve the promopt for microphone access and be allowed to complete calls as intended.
Let me know if this resolves your issue.


#7

Thanks but if I try to change that setting with Shields still up the screen redraws with device recognition still blocked.

If I turn (all) Shields off, at that point I no longer see any individual options, so my assumption was that everything – including device recognition – was enabled.

Isn’t it?

Also, the issue (at least from my side) is that I’m seeing that the call has been answered but I don’t hear the other party. So that’s not a ‘mic’ issue, is it? Seems to me it’s the incoming audio that’s being blocked.


#8

Still blocked? Can I see an screenshot of what youre referring to?


#9

Then I select:

GMail reloads (automatically).

I make a phone call. I don’t hear the ring. I see that the call is answered. I hear nothing.

I TURN SHIELDS BACK ON, THEN FOLLOW YOUR ADVICE:

Screen redraws showing the SHIELDS UP status.

Under ‘Device Recognition Blocked’ I choose ‘All device recognition allowed’.

Behind the dialog box I see GMail reload.

‘All device recognition allowed’ switches back to ‘Device Recognition Blocked’.


#10

I can’t say Ive ever seen that behavior before. I would be very interested in seeing this in action. Is there any way you’d be willing to grab a quick screen recording of this? It could help us uncover some (additional) latent Shields issues.

If you’re willing, the easiest way to do this would be to use LICEcap for screen recording (if you don’t have software that does this already. It’s open source, free and very simple to use. I’m specifically interested in seeing this behavior execute:


#11

Never done animated screen captures but I’ll look into it soon as I have a chance.

How is the output (presumably has to be saved as a file?) transferred to a reply message at community.brave.com – as an ‘upload’ from the message toolbar options?

In the meantime, the sequence of what happens is as I entered it in previous reply, moving down from the Shields UP status to Shields DOWN, then apparently needing to go back to Shields UP to select ‘Device Recognition Blocked’ and change it to ‘All device recognition allowed’ (which is my final action).

So the main thing is what happens in that last part of my previous message. When I try to ‘allow’ device recognition, GMail reloads behind the dialog box and simultaneously device recognition switches back to being ‘blocked’ (with no i/p from me).

BTW, why doesn’t my initial action – i.e., selecting Shields DOWN – include re-enabling device recognition – i.e., doesn’t Shields DOWN block all shields?

Thanks.


#12

Yep! If you use LICEcap (and again, I highly recommend it), you’ll record screen activity from within the LICEcap window on your screen. The recording will be saved as a gif in the destination you choose. You can drag and drop or use the upload button in the toolbar to embed them in your Community posts.

:point_up: This is exactly why I’m confused. I’d like to see what the actual behavior is for myself. Shields down (that is, disabled/off) should mean no protections are active on the site in focus.


#13

I’ll try to get to it over the weekend. If it’s just a matter of hitting a ‘record’ button & going through the sequence I’ve reported (i.e., no learning curve), shouldn’t be a problem.

Note that I won’t be able to ‘capture’ the calling from GMail, which is the crux of the problem (i.e., that I don’t hear the other party), so in the meantime, if you have a Mac available can you try turning Shields off and making a call from GMail (not Hangouts) & seeing whether the call goes through normally (using Brave Dev)?

I recall that turning Fingerprinting off in the release version worked without a hitch, so it seems to be a Dev issue. I use High Sierra (OS 10.13.5) but probably doesn’t matter which OS. Thanks.

UPDATE:

I d/l’d & installed the current standard version of Brave to compare. I am getting the same result except that ‘All device recognition allowed’ isn’t changing back to ‘Device Recognition Blocked’.

When I make a call from GMail I still don’t hear the phone ring (I did get the dialog re the mic and ‘allowed’ it) and didn’t hear the other party when the call was answered. I also tried the turning the global block off (“Shields down for this site”) & that didn’t work either.


#14

To sum up:

Whether I have all shields blocked or ‘All device recognition allowed’ I am not hearing the phone ring or the other party when they answer (in Call Phones From GMail).

This happens in both the current release version as well as Dev. The only difference is that ‘All device recognition allowed’ isn’t accepted in the Dev version, whereas it is in the release version (not to any practical effect, though). By “isn’t accepted” I mean that it doesn’t change to ‘allowed’ in Dev. Clicking on it just causes GMail to reload.

If simply changing the global Shields setting to Shields DOWN should also disable device recognition blocking, that seems to not be working. If it did work testing my issue would just be a matter of changing to shields DOWN and making a call from GMail, then noting whether the phone ringing &/or the called party answering could be heard.


#15

A short recording would really go a long way here.
I’m fairly perplexed because again, I’m able to perform phonecalls through Gmail without issue with these settings:

Additionally, that image was taken using the Developer build of Brave. So I’m quite perplexed here as to what could be causing the issue. Also, with respect to Shields, read this for more information on how Shields function in Brave.


#16

Is using LICEcap as simple as just pressing ‘Record,’ then going through the sequence of steps I’ve described & then pressing ‘Stop’?

Unfortunately, if there’s a learning curve it’ll have to wait. I just don’t have time to figure out new sfw at the moment.

Also, did you test Call Phones from GMail** on a Mac?

** (or Hangouts for that matter, as I’m having exactly the same results with that).

Thanks.


#17

:point_up: It’s as simple as that. Once you try it out you’ll realize right away just how easy it is:

  1. Launch LICEcap
  2. Adjust the window frame to the content you wish to record
  3. Hit record and select where to store the file
  4. Perform whatever actions you’d like recorded
  5. Hit stop.

#18

OK but my first step would be to turn ‘all shields off.’

No issues there.

My second step would be to place a call from GMail or Hangouts.

How am I then going to show with a screen capture that the call rings without my hearing it ringing or that I don’t hear the party when they answer?

Thanks.