Window problems, linux, debian

Description of the issue:

  1. Brave is always on my right monitor (dual monitor setup)

  2. The maximize window button in the top right corner of the window does not work, the Brave window is always maximized

  3. I can not drag the window and move it

  4. I can minimize it and max it back, if I click on its item in the bottom task bar

  5. Sporadically happens: if I max it back only a fully white/empty window/rectangle appears; restart is needed to see the content of the window again

  6. likely is an independent issue: I do not have the status bar (e.g. if I hoover an anchor element in a web page, I do not see the link at the bottom of the window (in the status bar, since there is no status bar)

How can this issue be reproduced?

  1. some of them always happen
  2. issue #5 happens 2-4 times a day

Brave Version( check About Brave):
Version 1.16.68 Chromium: 86.0.4240.111 (Official Build) (64-bit)

Additional Information:
I have disabled GPU hardware acceleration in the settings

1 Like

Hello @biohegedus

could you try to update brave then check if the issue still persist?

and have a nice day :slight_smile:

1 Like


I updated to Version 1.17.73 Chromium: 87.0.4280.67 (Official Build) (64-bit)
Now I see the links if I hover over them.
But the window resizing and position problems remained.

Thanks. And you have a nice day, too.

1 Like

I use debian and mate.

1 Like

you welcome and thanks a lot
let me ask one of the team @fmarier to help you

please notice it still weekend so maybe you get late response and have a nice day both of you :slight_smile:

1 Like

No problem. I started to use brave approx a month ago. I started to love it very much, so it is time to clean up the annoying things. A few more days is OK. Hopefully can be resolved.

Another thing: the window is not set as “always on top”, but the following happens:

  • focus is on brave win (call it w1, in the right monitor)
  • I click on other program’s window (call it w2, in the left monitor)
  • w2 is on top (left) and w1 (brave, right) gets in the back, and some other window will be on the top (right monitor)
  • if I defocus w2 (left) and focus any other window (still left) without going back to any win in the right monitor, brave win (w1) gets on the top without clicking
    (or something like that; I can not reproduce, but it happens pretty often)
1 Like

glad to see you happy with brave

by the way which version of debian you use
and did you install brave using the official repository or by snap ?

1 Like

debian 10 (buster, stable)
deb [arch=amd64] stable main

1 Like

thanks for the info :slight_smile:

1 Like

I also use Brave on Debian 10, though not with Mate, and haven’t seen that problem.

Here are two settings in brave://settings/appearance you might want to play with to see if either of them helps:

1 Like

Thanks a lot for these suggestions.
I set “use systetem…” and also “classic theme” - today I did not have any of the above mentioned problems.

1 Like

We are glad to know that your topic has been solved successfully, if you think that the Fmarier user has given you the best answer, click on the “Solution” button and Close the topic so that users can see it. First of all Thank you for sharing your problem, you help many users who have the same error.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.