[Ubuntu] Issues with Ubuntu's default dock and browser position

Hi, i have been having a couple issues with Brave that I don’t see happening with Chrome even after turning hardware acceleration on similar to what I’ve done with Brave. I’m using Ubuntu 21.10 (Default Ubuntu session with Dock) Intel i7 3770 Processor, AMD RX 570 graphics card, and two monitors.

The main issue that always happens is that when Brave is maximized, it doesn’t stay fully on the one screen. If the Ubuntu Dock is disabled, all is fine, but if it is Enabled (it’s there by default), then the close button and a narrow strip of the maximized Brave browser is shown on my secondary monitor, which is a portrait “1080x1920” 21" placed to the right of the main 27" 1440p monitor.

Note the area where Brave extends where past the Power icon (and tiny bit of black of the panel)

The other issue also appears to be with the dock. When minimizing a browser window that was previously half-maximized on the dock side of the screen, occasionally it will restore itself partially underneath the dock. I wasn’t able to reproduce this as it only seems to happen under certain circumstances, and I’m not sure if it is also an issue on Google Chrome/Chromium.

Thanks for your time!

The border issue that you mention happened to me as a result of having the Raw Draw flag enabled. I was able to fix this problem by going to the appearance settings in Brave and turning on “use system title bar and borders” or by disabling the Raw Draw flag.

I don’t have the option to “use system title bar and borders” but I have used it in the past. Perhaps something to do with using GNOME 40+?

But the issue is resolved with Raw Draw being turned off. Is there any downsides to having it disabled? Before I turned it off, it was set to default, which is enabled I guess?

Using a gnome environment shouldn’t effect it… I use Xfce (Linux Mint). It should be in your Brave settings. Click on settings, then go to the appearance setting. It should be right above the “Font size” setting and it’s titled “Use System title bar and borders”. I can never seem to find it either.
Raw Draw should make rendering pages a lot faster. As a result of the border issue I disabled it, because I figured it was unstable, but I just now enable it and I’ll see if I notice the speed gain.

Tested out Raw Draw. Unfortunately it’s unstable for me. It causes letters to disappear. If it doesn’t cause any issues, it should make browsing a lot faster.

Yeah the option isn’t there for me, I know it has been there in the past, both on GNOME and other desktops, but after resetting all my flags to default it seems to be not there still. Will check into see if it’s my launch flags. The other way to turn it on used to be right clicking the title bar and turning it on, but that also doesn’t exist.

I’m also having some issues with visual corruption of the “chrome” or UI elements of the browser itself, not the web page. I’ll see if resetting the flags will solve this issue, thanks for your time @Dingle.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.