Whatsapp Web not working on brave browser

Description of the issue:
Whatsapp Web is not working on the brave browser

Steps to reproduce

  1. Visit web.whatsapp.com
  2. scan the QR code

Expected result:
it will log in in my WhatsApp account

Brave Version( check About Brave): Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

Additional Information:
OS: Linux Mint 20.3 Cinnamon 64 bit
PS: tried reinstalling the brave browser, resetting to system defaults, and reinstalling WhatsApp on my phone. Nothing helped. WhatsApp web is working properly on the opera browser.

2 Likes

@rr96

https://community.brave.com/search?q=whatsapp%20in:title%20order:latest

WhatsApp workaround #1

Disable all Extensions.

WhatsApp workaround #2

Disable Honey extension - works for @raikpi:

WhatsApp workaround #3

Disable all Extensions. Test by Enabling each Extension, alone, one-at-a-time, to find the Extension that may be involved with the issue.

WhatsApp workaround worked for @Ath3lstan:

Reset Brave Browser > Settings: brave://settings/reset

Sometimes, the connection suddenly starts working:

WhatsApp workarounds at ‘guidelore.comworked for @incendiesq:

Brave Browser Nightly Version works for @Hugo_Zhor:

Works for @KevynOliveira

Works for @Nanotech

Works for @fran_xyz

Works for @naga1

Works for @vassdoki

Works for FreeStyler

Works for Aster

https://github.com/brave/brave-browser/issues?q=whatsapp+in%3Atitle+is%3Aissue+sort%3Aupdated-desc+

This issue only happens only on Brave since users can use the Brave web version with other browsers such as Google Chrome. While the issue hasn’t been addressed officially but there are a few possible ways to try the text messaging feature on Brave once more. I use and fixed with these steps.

I have tried all these methods but in vain. Whatsapp suddenly started working just and currently the chances of opening Whatsapp web is 9/10; yes sometimes the problem arises. I hope developers will fix this issue. Also, I only use brave browser.

1 Like

Nightly version works for me…

It definitely doesn’t work. Two browsers use too much resources. I found this, It seems a decent linux client:

UPDATE: It’s been 16 days and the problem is still here. In the meantime, I have probably received two updates from brave. Please fix this issue.

2 Likes

WhatsApp Web was working fine for me but asked me to update yesterday and it has since stopped working. I’ve cleared all cookies/local storage but each time I try to link device from the app, the browser spins for a bit and then tells me I’m not connected to the Internet, which I am. Brave doesn’t indicate that it’s blocking any resources and there are no other blockers enabled.

What worked for me is setting “Trackers & ad-blocking”, “Block fingerprint”, and “Block cookies” all to disabled, then enabling them back once logged in.

1 Like

I found a solution. For me it was only working on Chrome and on a window with tor.

When it was not working on a normal window, my laptop was connected with an ethernet cable and my phone was on the wifi of the same router.

I turned off wifi on my phone and connect my laptap via wireless.

It worked. Connected to whatsapp web with no problems.

1 Like

I can’t belive whatsapp web is working fine on all browser except Brave… come on, I don’t want to go back to Chrome just because of this.

2 Likes

i tried so many times to fix this, im very close to give up and use another browser, brave devs really dont care

1 Like

The problem is still there but it has become less frequent over the last few days. Let’s see what happens.

1 Like

Resetting worked for me! I hope the issue doesn’t repeat since it would be a hassle to be doing this frequently.

1 Like

Reset permissions for web.whatsapp.com worked for me!
Link: brave://settings/content/siteDetails?site=https%3A%2F%2Fweb.whatsapp.com

1 Like

In my case disabling the keepa extension did the trick!

1 Like

I found help on this page;. Thanks for everybody’s posts.

I am on Arch Linux. Disabling all extensions worked for me (I only had Ghostery installed). Enabling the extension after logging into WhatsApp worked fine.

1 Like

disabling all extension and deleting data worked for me

1 Like

Disabling “Ghostery” add-on worked for me.
It’s odd, but the same add-on does not seem to create a problem on Chrome browser with WhatsApp Web.

1 Like

All of those methods simply don’t work. I mean resetting permissions, disabling all extensions, clearing data, etc.