Whatsapp Web is not working

for them, this is not a big issue, now I’m using opera or chrome it’s working fine, try for an alternative.

Thank you so much! This actually worked, I did not expect that. I have been frustrated by this issue for weeks now and had been using firefox especially for whatsapp web. You are awesome!

Its frustrating that things just start randomly stop working and our options are to use another browser…

2 Likes

I don’t have the Honey extension installed, but I think one of my extensions was breaking it. I turned off all my extensions (I used the “Disable Extensions Temporarily” extension, but you can also manually do it) and then I was able to log in without a problem.

After I logged in, I reenabled my extensions and it still worked, even after restarting Brave. Curious if this works for others.

2 Likes

@dmaz99

Thanks for the tip, re Disable Extensions Temporarily extension

Ref.:

I did not reset all my settings, but created a new user and started brave for the first time. This browser window did not have any problem linking whatsapp.
Ubuntu Unity 22.04, Brave [Version 1.40.113 Chromium: 103.0.5060.114 (Official Build) unknown (64-bit)]

So it must be a setting or an extension.
Then I disabled all my extensions, and my main brave browser started to wok.

This is what worked for me alltogether:

  • Disabled secure dns
  • Turned off shield for web.whatsapp.com
  • Disabled all extensions.

After this I was able to link the device and whatsapp started to work.

1 Like

That worked perfectly. Thanks!!!

I found a solution. For me it was only working on Chrome and on a window with tor.

When it was not working on a normal window, my laptop was connected with an ethernet cable and my phone was on the wifi of the same router.

I turned off wifi on my phone and connect my laptap via wireless.

It worked. Connected to whatsapp web with no problems.

I hope it helps.

1 Like

THANKS !!! This fixed the problem. :grinning:

16/07/2022
Brave still not working with Whatsapp web.

after reset the settings(restore setting to their orginal default) then whtasapp web working fine with me.

[
Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (64-bit)

I am facing the same issue. Exact same error in the console

Facing the same issue, please give solutions

Whatsapp web working fine on all browsers except Brave for some reason… workarounds don’t seem to help my case.
Hopefully they can fix this.

Guys, I created this post more than 1 month ago and we never received an effective solution to solve the root of this problem. I do not find it acceptable that we, as users, have to be changing so many settings to fix something that the developers should fix. I personally switched browser a while ago. It just doesn’t seem acceptable to me.

I’m having that exact issue with the browser, my whatsapp session is not kept when i close the browser and every time i try to use it again i get the qr code and then i get the logout screen and have to scan again, lucky if i don’t have to wait minutes to get the page to load. This doesn’t happen with firefox or edge.

At this point I haven’t been able to use WhatsApp Web for over a month. 2 days ago I switched to Opera, because it is absolutely unacceptable for Brave to not do anything about this.

Yes I get the same - had been working fine for over a year with number of updates including both Brave and WA) and started 9 June 2022 after a WA upgrade (version now 2.22.3.77). So naturally had a go at WA/Meta but getting any sense out of them was useless. 10-6-2022 they replied saying “If you’re using WhatsApp Web, please restart your browser.” I mean…

But something has changed now because using Brave 1.40.107 it still throws this error BUT now using Chrome it works seamlessly. Looks like whatever happened in the upgrade to WA 2.22.3.77 broke something in Brave AND BRAVE HASN’T YET RESPONDED. You know… couple of months n’ all that…

Moral of the story:
USERS: use an alternative browser

BRAVE TEAM: for goodness sake get on with it and “work arounds fixing settings” just doesn’t cut it tbh. This is meant to be simple for mere mortals (like me) not hackers (also like me but I don’t intend to make it my life’s work diagnosing splurgeware that has a paid maintenance team…)
Please go fix the default settings…

2 Likes

thanks, work for me. thanks this method worked for me

This is sad… We made any comments and pointed many issues about this case, but nothing happens, even with the updates rolling during this situation.
For many, the solution was to migrate to other (Ophera, Chrome, FireFox), it’s sad for me see this, because i beleave on Brave browser…

I think the staff coud inform us about what they are mading about this, any news, even “whe know but don’t know yet how to solve” serves to us…
The resolution propose (informed by us and not the staff) in this topic (about reset settings to work and repeat after some time to work again) it’s not the real solution, it’s a placebo because works for a while and stops…