Whatsapp Web doesn't work on latest brave

Not sure this is the right place to report a bug, but since the second to last update, whatsapp web no longer works on brave; instead, it says it only supports chrome and so on. I’ve tried with shields up and down, with scripts on and off, with fingerprinting on and off - and I cleared the cookies.

I’m now on Version 0.67.55 Chromium: 75.0.3770.38 (Official Build) nightly (64-bit) after today’s update

Any ideas why it should so suddenly and so completely stop working? Has anyone else tried it? Perhaps it’s just on my side

https://web.whatsapp.com/ link for the lazy

@Presently42 just tried it and it didn’t load up the qr code with the shield up

@Dgenies But the page loaded without saying that only chrome et al. are supported? So it’s on my end. I’ve cleared the cookies already and tried both with shields up and down; maybe an extension is being silly, so I’ll try that next

Edit: definitely not an extension, nor is there a single whatsapp cookie to delete, nor are the shields causing the problem, as I tried both up and down. What else might be the cause?

For me it stopped working today (was working until yesterday). It is saying Whatsapp web needs Chrome 36+ to work. Even changing the User Agent string to something else (e.g. that of Firefox) doesn’t help.

As of Version 0.68.18 Chromium: 75.0.3770.75 (Official Build) (64-bit), it works again.

It doesn’t work in ios. This is particularly annoying on iPad (as there is no WhatsApp app).

It’s an issue with WhatsApp itself. They are blocking the Brave user agent (probably on purpose). They are also doing it with Vivaldi. The Vivaldi team found a solution pretty fast though.

Whatsapp is working again with the latest update of the brave developer branch (Version 0.67.79 Chromium: 75.0.3770.80 (Official Build) dev (64-bit))

Thank you very much for providing an update that fast after the issue appeared! You definitely earned all my rewards this month.

@Presently42 Thanks for reaching out. Issue is already logged please track the issue here.


@Belgarion this has been fixed and should be in our next Dev channel build :slight_smile: We should have a new build out today or tomorrow if one hasn’t already been pushed out (you can always manually check for updates)

Sorry for the inconvenience :frowning: