Whatsapp web not working in Brave

Brave Browser does not support Whatsapp Web.

It never connects and immediately logs out.

Fix this issue in Brave

I’m facing same issue… can someone from the community help us ?

Could you try with shields off?
Let us know if that works.

Ater shields off also did not work.

Reset permissions for web.whatsapp.com.

Also check by turning off one extension by one at a time to check if an extension is causing this

exactly the same issue with me ! its not working only in brave i tried in chrome and edge and its working well and good only with brave it shows error

@Mattches @steeven @Chocoholic @Saoiray @Aman_M @rodrige any fixes you can think of ?

Known issue that has been persistently hard to identify. Various workarounds that work for some users and not others. Posting the information below. If the suggested workarounds do not work for you, try digging into the GitHub issue reports and the linked topic. Other things identified there that may work in your case. You should probably keep track of the issue report and community topic linked below. Any updates will probably be posted in either of those places.

ISSUE: Whatsapp Not Working
Workaround:

  1. Disasble Honey extension if installed (other extensions too have been culprit)
  2. Disable Use hardware acceleration when available at brave://settings/system
  3. Close and relaunch Brave

Topic Reference: Whatsapp Web is not working
Most active Community topic which has other workarounds (along with the GitHub issue report below) that also worked for some users

Brave GitHub Issue Report (Source):
Web.whatsapp.com fails to authenticate and returns “Make sure you computer has an active internet connection”

Above Information from: User Solutions: Brave Release 1.43.x

Yes It is working now after disable the hardware acceleration & Brave Shield up

1 Like

Yes! Glad one of the suggested workarounds worked in your case. :slightly_smiling_face:

You should mark your above post as the solution so that others will know your issue is solved at least for the time being. It will also help other users experiencing the same problem and looking for a solution. :slightly_smiling_face: